Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Emails being sent ...but they are empty


Guest

Recommended Posts

Hi,

 

I've been messing around trying to get SMTP authentication working with a mail factory contrib.

 

Anyway finally got it working so that mail sent from the site is relayed via my free Yahoo! mail account.

 

If you click contact us, and type a message, the message is sent successfully to me, via yahoo mail, but the main body of the email is blank! The subject however is intact and is sent.

 

This is the same for when you register a new account. A welcome email is sent to me, with the correct subject etc, but the email is just blank, with a bit of yahoo advertising at the footer!

 

Any time I use my own mail server, it works fine, but I cant use my own email server as its on the Dynamic User List and blocked by many common ISP's.

 

I looked at the account_create and the account create_success.php files and they are all okay with the body bit of the email looking like it should be sent from them.

 

Is yahoo filtering the message out somehow ? or is it something to do with my meddling of the site.

 

Im pretty stumped.

 

Cheers for any info :)

 

Bod.

Link to comment
Share on other sites

Hi,

 

I've been messing around trying to get SMTP authentication working with a mail factory contrib.

 

Anyway finally got it working so that mail sent from the site is relayed via my free Yahoo! mail account.

 

If you click contact us, and type a message, the message is sent successfully to me, via yahoo mail, but the main body of the email is blank! The subject however is intact and is sent.

 

This is the same for when you register a new account. A welcome email is sent to me, with the correct subject etc, but the email is just blank, with a bit of yahoo advertising at the footer!

 

Any time I use my own mail server, it works fine, but I cant use my own email server as its on the Dynamic User List and blocked by many common ISP's.

 

I looked at the account_create and the account create_success.php files and they are all okay with the body bit of the email looking like it should be sent from them.

 

Is yahoo filtering the message out somehow ? or is it something to do with my meddling of the site.

 

Im pretty stumped.

 

Cheers for any info :)

 

Bod.

 

 

EDIT!:

 

Just tried relaying from my ISP (ntlworld) and that also gives a blank email body text.

 

Whats up! sommets seriously down the pan :(

Link to comment
Share on other sites

I have the same problem, and I wondering if by any change you installed the contrib Fancier Invoice.

 

Denice

 

No its not that contrib,

 

I "think" it seems to have happend after I tried to get SMTP mail authentication working with my yahoo mail account - using one of those free contribs - i think it was mail factory.

 

Everything is working fine except there is just no text in the main body of the message :(

Link to comment
Share on other sites

No its not that contrib,

 

I "think" it seems to have happend after I tried to get SMTP mail authentication working with my yahoo mail account - using one of those free contribs - i think it was mail factory.

 

Everything is working fine except there is just no text in the main body of the message :(

 

I have the same problem, emails are being sent but the body is empty. However I just installed the points and rewards contrib and the welcome email of that contrib is sent correctly.

 

I don't know how to solve this, has been this way for a couple of months know, but nobody seems to have the answer for this.

 

I don't know the contrib you are talking about, so we can assume that that isn't the problem also

 

Denice

Link to comment
Share on other sites

I have the same problem, emails are being sent but the body is empty. However I just installed the points and rewards contrib and the welcome email of that contrib is sent correctly.

 

I don't know how to solve this, has been this way for a couple of months know, but nobody seems to have the answer for this.

 

I don't know the contrib you are talking about, so we can assume that that isn't the problem also

 

Denice

 

Sorted mine now, basically restored my old email.php's from backup then did a few more bits n bobs and its working now - touch wood!

Link to comment
Share on other sites

Sorted mine now, basically restored my old email.php's from backup then did a few more bits n bobs and its working now - touch wood!

I also tried step 1 from you fix, but that alone did not help, what where the "bits n bobs" you did. Could you give some more detailed info as to what you did?

 

Denice

Link to comment
Share on other sites

I also tried step 1 from you fix, but that alone did not help, what where the "bits n bobs" you did. Could you give some more detailed info as to what you did?

 

Denice

 

Have you checked that everythings okay in php.ini ??

 

Restoring to the original email.php's sorted it for me, you do know that there is 2 of them ?

Link to comment
Share on other sites

This debate is going nowhere - sorry! E-mail in osCommerce is set to send from 'localhost' which is your domain - and it's not meant to go from an e-mail address which is not based on your domain. [email protected] is fine but [email protected] isn't.

 

If your host doesn't provide you with sendmail or smtp then get a new host.

 

Vger

Link to comment
Share on other sites

That's what I said - get a new host.

 

Vger

 

Not too bothered about it to be honest, the mail reply address is set to my domain email address.

 

You reccommend any that give you smtp aswell ?

 

Bod.

Link to comment
Share on other sites

Basically, Yahoo is absolute rubbish for hosting osCommerce websites, ditto Lycos, ditto PowWeb. MOST hosting companies provide an smtp service - and if you find companies that don't offer it just mark them down as 'bad' or 'unsuitable'.

 

Can't actually recommend hosts here, but here's a few things to look for that'll make your life easier:

1. Register Globals is set to 'On' - no need to patch the files, and most contributions are written to work with Register Globals set to 'On'.

2. Sendmail and SMTP available

3. Make sure Safe Mode is 'off' and not 'on', because if they run PHP in Safe Mode you get more problems.

4. Avoid Windows hosts - because they are more likely to have Register Globals 'off' and Safe Mode 'on'

 

Vger

Link to comment
Share on other sites

Im in a strange situation though, I only use the domain name for email and also to point to my website, I host my own server at home, on Windows lol

 

I cant face porting my install here to a proper ISP, its taken me ages to get all the contribs installed and get everything workign hunky dory.

 

The only thing is that I hope the search engines dont delete me if they find out Ive got a dynamic ip address (even though it never actually changes) I was in Yahoo! search lastnight, but now ive gone completely almost like the removed me ! Oh wo me :(

 

Cheers, :D

Bod.

Link to comment
Share on other sites

This debate is going nowhere - sorry! E-mail in osCommerce is set to send from 'localhost' which is your domain - and it's not meant to go from an e-mail address which is not based on your domain. [email protected] is fine but [email protected] isn't.

 

If your host doesn't provide you with sendmail or smtp then get a new host.

 

Vger

 

I use my domain to send and receive emails, I already checked with my host to see if it was a problem cost by the host, and it wasn't. I have no problem with receiving or sending emails. My problem is that the body of some , not all, emails like contact us, create account and order emails are empty except the subject.

 

So as you see this debate is usefull!!!

 

Denice

Link to comment
Share on other sites

My problem is that the body of some , not all, emails like contact us, create account and order emails are empty except the subject

 

In which case I'd suggest that you are the victim of time-outs during the operation of those scripts. You can increase the time allowed for the execution of php commands if you have access to a local copy of php.ini, or you may be able to do it via .htaccess, or even via something like "set_time_limit(0);" within the file itself - but be careful with increasing the max execution time for php scripts - it can cause major problems if set too high.

 

Vger

Link to comment
Share on other sites

In which case I'd suggest that you are the victim of time-outs during the operation of those scripts. You can increase the time allowed for the execution of php commands if you have access to a local copy of php.ini, or you may be able to do it via .htaccess, or even via something like "set_time_limit(0);" within the file itself - but be careful with increasing the max execution time for php scripts - it can cause major problems if set too high.

 

Vger

 

Hi Vger,

 

Thank you, for your responds.

 

I read you post (3 times) and I would like to give it a go, I have a php.ini file and .htacces, so I can do what you suggested (the moment I figured it out).

 

I'm normaly not easily scared but the words "major problems" screams caution to me.

 

Could you explain to me what to look for or what and how to change?

 

Denice

Link to comment
Share on other sites

Hi Vger,

 

Thank you, for your responds.

 

I read you post (3 times) and I would like to give it a go, I have a php.ini file and .htacces, so I can do what you suggested (the moment I figured it out).

 

I'm normaly not easily scared but the words "major problems" screams caution to me.

 

Could you explain to me what to look for or what and how to change?

 

Denice

 

Sorry for this second post, when I try my contact us, I get the message that the message was send, but as stated before without body. (I forgot to mention it in my post before, and I want to besure that we try the right fix)

 

Denice

Link to comment
Share on other sites

In php.ini you'll see a record for 'max_execution_time=' and this is usually set to 30 (seconds). You can try setting it to 45, but I wouldn't recommend more than that.

 

In .htaccess, in the root of your website, you'd need to add an entry like this:

 

php_value max_execution_time 45

 

Vger

Link to comment
Share on other sites

In php.ini you'll see a record for 'max_execution_time=' and this is usually set to 30 (seconds). You can try setting it to 45, but I wouldn't recommend more than that.

 

In .htaccess, in the root of your website, you'd need to add an entry like this:

 

php_value max_execution_time 45

 

Vger

I made the change to the php.ini (wasn't allowed to change the .htacces) but it didn't work. Can you help with some other suggestion :blush:

 

Denice

Link to comment
Share on other sites

These features, provided your files are installed correctly, should work 'out of the box'. I can only assume that it is something to do with the way in which your server is set up, or that it is overloaded and suffers occasional time outs because there are just too many websites trying to execute php scripts at the same time.

 

As a last resort (before changing hosts) check your files against a default osCommerce set of files, using something like the Compare Files feature in a programme like Text Pad (free download).

 

Vger

Link to comment
Share on other sites

These features, provided your files are installed correctly, should work 'out of the box'. I can only assume that it is something to do with the way in which your server is set up, or that it is overloaded and suffers occasional time outs because there are just too many websites trying to execute php scripts at the same time.

 

As a last resort (before changing hosts) check your files against a default osCommerce set of files, using something like the Compare Files feature in a programme like Text Pad (free download).

 

Vger

Just to make sure that I check all the correct files;

 

the 2 email.php

contact_ us php

create_account.php

order.php

 

Are there any more I need to check, and how can I see if the sql (if there is an sql for emails) is correct?

 

Denice

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...