Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Warning messages


freya

Recommended Posts

This comes up at the Catalog- side:

 

Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid is 198732 is not allowed to access owned by uid 0 in /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php on line 148

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php:148) in /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php on line 97

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php:148) in /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php on line 97

 

Warning Warning: I am able to write to the configuration file: /customers/njorun.be/njorun.be/httpd.www/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

And this at the Admin-side:

 

Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid is 198732 is not allowed to access owned by uid 0 in /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php on line 110

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php:110) in /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php on line 67

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php:110) in /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php on line 67

 

Please help me, my hair turns more grey every day I?m searching for ansvers . Would like to have my shop up and working before cristmas :)

 

/ Freya

Link to comment
Share on other sites

This comes up at the Catalog- side:

 

Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid is 198732 is not allowed to access owned by uid 0 in /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php on line 148

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php:148) in /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php on line 97

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php:148) in /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php on line 97

 

Warning Warning: I am able to write to the configuration file: /customers/njorun.be/njorun.be/httpd.www/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

I tryed to change settings for configure.php, using Filezilla. But it keeps changing back to 644 both from 400 and 444. The pre-install change to 777 was ok.

 

And this at the Admin-side:

 

Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid is 198732 is not allowed to access owned by uid 0 in /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php on line 110

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php:110) in /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php on line 67

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php:110) in /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php on line 67

 

 

 

Please help me, my hair turns more grey every day I?m searching for ansvers . Would like to have my shop up and working before cristmas :)

 

 

/ Freya

Link to comment
Share on other sites

This comes up at the Catalog- side:

 

Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid is 198732 is not allowed to access owned by uid 0 in /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php on line 148

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php:148) in /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php on line 97

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php:148) in /customers/njorun.be/njorun.be/httpd.www/includes/functions/sessions.php on line 97

 

Warning Warning: I am able to write to the configuration file: /customers/njorun.be/njorun.be/httpd.www/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

And this at the Admin-side:

 

Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid is 198732 is not allowed to access owned by uid 0 in /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php on line 110

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php:110) in /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php on line 67

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php:110) in /customers/njorun.be/njorun.be/httpd.www/admin/includes/functions/sessions.php on line 67

 

Please help me, my hair turns more grey every day I?m searching for ansvers . Would like to have my shop up and working before cristmas :)

 

/ Freya

 

 

You have three different things going on

 

#1 safemode problem- You need to talk to your hosting company as this needs to be changed in the php.ini file

 

#2 Headers already sent error- You can find the answer in the knowledge base HERE

 

#3 Write permissions on you configure.php file- You need to chmod the file removing the write permissions and this error message will go away.

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

You have three different things going on

 

#1 safemode problem- You need to talk to your hosting company as this needs to be changed in the php.ini file

 

#2 Headers already sent error- You can find the answer in the knowledge base HERE

 

#3 Write permissions on you configure.php file- You need to chmod the file removing the write permissions and this error message will go away.

 

 

My host (B-one) has default SAFE_MODE ON and does not make any changes. Is there any other way to get rid of this prblem?

 

Has deleted the whitspaces but there is no change. Is that because safe mode is on??

 

Using Filezilla but it is impossible to change write- permission for owner. I can set permission 600 but not 400.

 

 

/Freya

 

need all the help I can get

Link to comment
Share on other sites

Found a solution to the pink warning message in forum. Changed in header.php to "false" . I don?t remember vere I found this file, my head feels totelly empty now, but it worked.No more warning i can write.... and since cmod is 644 in both configure files there cant be any risks by setting False" in header, can it?

 

Now there is only the problems with safe mode and sessions..

 

Since b-one won?t change default setting safe_mode on and says there are other?s that use osC without any problems there has to be a way to go round that problem to I guess.

 

Any suggestions??

 

Freya

forever greatful for all yor help

Link to comment
Share on other sites

Found a solution to the pink warning message in forum. Changed in header.php to "false" . I don?t remember vere I found this file, my head feels totelly empty now, but it worked.No more warning i can write.... and since cmod is 644 in both configure files there cant be any risks by setting False" in header, can it?

 

Now there is only the problems with safe mode and sessions..

 

Since b-one won?t change default setting safe_mode on and says there are other?s that use osC without any problems there has to be a way to go round that problem to I guess.

 

Any suggestions??

 

Freya

forever greatful for all yor help

Best regards

Kjolebutikken

Link to comment
Share on other sites

Hi Freya, I have exact same tree error messages as you. Have not found any solution so please answer me if you or any others have.

 

What did you change to "false" in the header.php file that worked?

 

Please help me anyone:-))))

 

Best regards:-)

Kjolebutikken

Best regards

Kjolebutikken

Link to comment
Share on other sites

Hi Beate

 

I don?t remember wer heder.php are located, but I shall try to find it tomorrow. If you have a way to secure admin I?m forever grateful. Ther are alredy .htaccess files in /admin/ and /admin/admin/ both of them size 1006 according to FileZilla. Have tryed to remove one and replace it with the .htaccess that my host tells me to have but that only results in another Error message.

 

I dont know what to do now, tryed everything I foun here...

 

Freya

Link to comment
Share on other sites

Hi Beate

 

I don?t remember wer heder.php are located, but I shall try to find it tomorrow. If you have a way to secure admin I?m forever grateful. Ther are alredy .htaccess files in /admin/ and /admin/admin/ both of them size 1006 according to FileZilla. Have tryed to remove one and replace it with the .htaccess that my host tells me to have but that only results in another Error message.

 

I dont know what to do now, tryed everything I foun here...

 

Freya

 

Hi Freya. I'm using b-one as host. This is what I did to enable password protection to the admin folder. I used the codes given by my host first and pasted them in a new notepad. This did work for the .htpasswd file, but not for the .htaccess file. I got the same problem as you, I was asked to replace, and when I did, it changed back to as before. What I did now, I pasted the code from my host into the already excisting .htaccess file and saved it. Then it worked. When I opened the admin in the explorer browser, I was asked for username and password and when I did, admin opened.

 

I had to use the excact same username and password as to log into my controlpanel on b-one's server. Or else it did not work.

 

I also had to encrypt my password.

 

Check out this page. here is the procedure for the codes to put in the .htaccess file and the .htpasswd file and also the link for encrypting your password.

 

I also found this in one of these discussions as anser to the same problem we have:

 

.....

Your hosting company is running PHP in Safe Mode. This means that even if you have decided to store sessions in the database and not in files in a 'tmp' folder you have to provide a full pathway to your 'tmp' folder in your osC admin panel under Configuration --> Sessions.

 

The pathway, by default, shows as tmp/ and this needs to be changed to your full DIR_FS_CATALOG pathway (as in your includes/configure.php file), with the addition of tmp/ on the end of it. So if your DIR_FS_CATALOG pathway is /var/www/html/ then your session directory pathway would be /var/www/html/tmp/

 

The other errors are caused by the first and will disappear when this is resolved.

.....

 

My problem is that for some reason I suddenly cannot enter the admin section at all. The password log-in does not come up either anymore, so I must have done something after that, but I don't know what.

 

Hope this helps and look forward to hear from you again regarding the header.php file. I found one in

/catalog/admin/includes. But I did not understand what you said about changing to false. Did you open the file and changed in the code? What did you change to "false" and where?

 

If anyone else have any suggestions for me, please gove me some help.

 

Kjolebutikken:-)

Best regards

Kjolebutikken

Link to comment
Share on other sites

Hi Freya. I'm using b-one as host. This is what I did to enable password protection to the admin folder. I used the codes given by my host first and pasted them in a new notepad. This did work for the .htpasswd file, but not for the .htaccess file. I got the same problem as you, I was asked to replace, and when I did, it changed back to as before. What I did now, I pasted the code from my host into the already excisting .htaccess file and saved it. Then it worked. When I opened the admin in the explorer browser, I was asked for username and password and when I did, admin opened.

 

I had to use the excact same username and password as to log into my controlpanel on b-one's server. Or else it did not work.

 

I also had to encrypt my password.

 

Check out this page. here is the procedure for the codes to put in the .htaccess file and the .htpasswd file and also the link for encrypting your password.

 

I also found this in one of these discussions as anser to the same problem we have:

 

.....

Your hosting company is running PHP in Safe Mode. This means that even if you have decided to store sessions in the database and not in files in a 'tmp' folder you have to provide a full pathway to your 'tmp' folder in your osC admin panel under Configuration --> Sessions.

 

The pathway, by default, shows as tmp/ and this needs to be changed to your full DIR_FS_CATALOG pathway (as in your includes/configure.php file), with the addition of tmp/ on the end of it. So if your DIR_FS_CATALOG pathway is /var/www/html/ then your session directory pathway would be /var/www/html/tmp/

 

The other errors are caused by the first and will disappear when this is resolved.

.....

 

My problem is that for some reason I suddenly cannot enter the admin section at all. The password log-in does not come up either anymore, so I must have done something after that, but I don't know what.

 

Hope this helps and look forward to hear from you again regarding the header.php file. I found one in

/catalog/admin/includes. But I did not understand what you said about changing to false. Did you open the file and changed in the code? What did you change to "false" and where?

 

If anyone else have any suggestions for me, please gove me some help.

 

Kjolebutikken:-)

 

 

Hi again, just got some valuable help from AlanR, and IT DID WORK for me. All warnings dissapeared except for the pink:

 

Warning: I am able to write to the configuration file: /customers/kjolebutikken.com/kjolebutikken.com/httpd.www/nettbutikk/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

And I'm now able to open admin tools and catalog again:-)))))

Follow the instructions here:

 

......

Cause : Previous bug in PHP fixed in latest version (Chances are your ISP has updated to the new version)

 

 

Fix: Goto Admin / Configuration / Sessions and change the "Sessions Directory" to tmp (no slashes)

 

If you can't get into Admin, goto your Database Admin page (usually PhPAdmin app.)

Click on any table on the left hand side.

Click on SQL at the top of the screen

Overtype whatever appears in the SQL window with ...

 

 

QUOTE

UPDATE configuration SET configuration_value = 'tmp' WHERE configuration_key='SESSION_WRITE_DIRECTORY'

 

 

Click GO

.......

 

 

Please contact me about the header.php file if this is what removed the "pink" warning I still have.

 

Best wishes for your progress for your site:-)

Kjolebutikken

Best regards

Kjolebutikken

Link to comment
Share on other sites

Hi again, just got some valuable help from AlanR, and IT DID WORK for me. All warnings dissapeared except for the pink:

 

Warning: I am able to write to the configuration file: /customers/kjolebutikken.com/kjolebutikken.com/httpd.www/nettbutikk/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

And I'm now able to open admin tools and catalog again:-)))))

Follow the instructions here:

 

......

Cause : Previous bug in PHP fixed in latest version (Chances are your ISP has updated to the new version)

Fix: Goto Admin / Configuration / Sessions and change the "Sessions Directory" to tmp (no slashes)

 

If you can't get into Admin, goto your Database Admin page (usually PhPAdmin app.)

Click on any table on the left hand side.

Click on SQL at the top of the screen

Overtype whatever appears in the SQL window with ...

 

UPDATE configuration SET configuration_value = 'tmp' WHERE configuration_key='SESSION_WRITE_DIRECTORY'

Click GO

.......

Please contact me about the header.php file if this is what removed the "pink" warning I still have.

 

Best wishes for your progress for your site:-)

Kjolebutikken

 

 

Hi again. I have NO WARNINGS anymore. Just wanted to inform you. To remove the "pink" warning:

 

Warning: I am able to write to the configuration file: /customers/kjolebutikken.com/kjolebutikken.com/httpd.www/nettbutikk/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

I did this:

 

Create a php file named "secure.php" or whatever. Put the following code in it:

 

 

<?php

chmod('includes/configure.php', 0444);

?>

 

 

Upload this file to your server in the Catalog folder. Then run it in your browser: http://www.yourwebsite.com/catalog/secure.php

 

Nothing will show on the screen, but the file will run and will set the permissions.

 

I ensured that there was no white spaces in the beginning and end of the code and saved the file.

Again AlanR was the one to "save" me.

 

Hope you can use these solutions if you still hav problems on your site.

Good luck to you:-)

 

Best wishes

Kjolebutikken

Beate

Best regards

Kjolebutikken

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...