Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Home page does not load in IE but works in firefox


Guest

Recommended Posts

no problem from here in IE

 

 

Hi Please try and take a product to checkout. then delete it and then go back to the home page.

 

I think you will see the problem come back..

Link to comment
Share on other sites

Hi Please try and take a product to checkout. then delete it and then go back to the home page.

 

I think you will see the problem come back..

 

well, you need to check your code :

 

<td align="right" class="productListing-data" valign="top"><b><span class=currency_symbol>?/span>49.99<span class=currency_symbol></span></b></td>

 

see the "class=currency_symbol>?/span>" part ? from shopping_cart.php ?

Treasurer MFC

Link to comment
Share on other sites

well, you need to check your code :

 

<td align="right" class="productListing-data" valign="top"><b><span class=currency_symbol>?/span>49.99<span class=currency_symbol></span></b></td>

 

see the "class=currency_symbol>?/span>" part ? from shopping_cart.php ?

 

 

Ive been trying to figure out how to fix that? possibly it may be a css thing that is causing the currency_symbol issue.

 

but is the whole site working in your IE? and what version of IE do you have? it seems IE, Opera do not like the home page and do not load the rest of the products or the footer.

Link to comment
Share on other sites

Ive been trying to figure out how to fix that? possibly it may be a css thing that is causing the currency_symbol issue.

 

but is the whole site working in your IE? and what version of IE do you have? it seems IE, Opera do not like the home page and do not load the rest of the products or the footer.

 

this is not css, you are outputting wrong html and that can only come from your php code.

no matter the version, if your html is wrong, you need to correct it.

As it is now, your shoppingcart does not show any prices etc.

Treasurer MFC

Link to comment
Share on other sites

this is not css, you are outputting wrong html and that can only come from your php code.

no matter the version, if your html is wrong, you need to correct it.

As it is now, your shoppingcart does not show any prices etc.

 

 

In Firefox my shopping cart shows full prices and details, so i dont understand why it is not working in IE.

 

Have you got Firefox installed to see the difference.

Link to comment
Share on other sites

In Firefox my shopping cart shows full prices and details, so i dont understand why it is not working in IE.

 

Have you got Firefox installed to see the difference.

 

yes, I see that but some browsers are more particular about html coding standards than others.

So if you want it to show correctly in all browsers you need to correct the way you output html.

Treasurer MFC

Link to comment
Share on other sites

this is not css, you are outputting wrong html and that can only come from your php code.

no matter the version, if your html is wrong, you need to correct it.

As it is now, your shoppingcart does not show any prices etc.

 

Hi Amanda,

 

Are you talking about the home page part not loading in IE because of bad HTML or the shopping car "currency_code" part?

 

Do you think you could help me find the bug causing the home page not to load in IE? as I have been hunting for it but cant find it.

Link to comment
Share on other sites

Hi Amanda,

 

Are you talking about the home page part not loading in IE because of bad HTML or the shopping car "currency_code" part?

 

Do you think you could help me find the bug causing the home page not to load in IE? as I have been hunting for it but cant find it.

 

 

your homepage is loading but even there you have this :

 

<tr><td height=49 bgcolor=#F4F4F4 class=ch3 align=center><span class=currency_symbol>?/span>125.00<span class=currency_symbol></span></td></tr>

 

so I would start by checking where and how you output price information.

 

or things like this where javascript is inserted out of the blue and never included or closed.

 

 

<tr><td class=tx style="padding-left:10px; padding-right:10px"><div class="tab-page" id="tab-pane-1">

 

<script type="text/javascript">

var ...</td></tr>

<tr><td height=2></td></tr>

<tr><td><img src=images/m26.gif width=128 height=1></td></tr>

<tr><td height=15></td></t

Treasurer MFC

Link to comment
Share on other sites

your homepage is loading but even there you have this :

 

<tr><td height=49 bgcolor=#F4F4F4 class=ch3 align=center><span class=currency_symbol>?/span>125.00<span class=currency_symbol></span></td></tr>

 

so I would start by checking where and how you output price information.

 

or things like this where javascript is inserted out of the blue and never included or closed.

<tr><td class=tx style="padding-left:10px; padding-right:10px"><div class="tab-page" id="tab-pane-1">

 

<script type="text/javascript">

var ...</td></tr>

<tr><td height=2></td></tr>

<tr><td><img src=images/m26.gif width=128 height=1></td></tr>

<tr><td height=15></td></t

 

 

That javascript is for the Tabs in the product information box. when you click details, it gives the yellow tabs. that seems to be working fine..

 

But on the home page, the tabs are not there so its not this problem... I have also tried removing the code for the tabs (the above javascript) completly and the site still does not work i IE.

Link to comment
Share on other sites

That javascript is for the Tabs in the product information box. when you click details, it gives the yellow tabs. that seems to be working fine..

 

But on the home page, the tabs are not there so its not this problem... I have also tried removing the code for the tabs (the above javascript) completly and the site still does not work i IE.

 

that code is from your homepage and would be a problem on any page.

 

load your homepage in your browser and view the source.

Treasurer MFC

Link to comment
Share on other sites

that code is from your homepage and would be a problem on any page.

 

load your homepage in your browser and view the source.

 

 

Hi Amanda,

 

You are completely right about the Javacode stopping the homepage from loading in some browsers.

 

I have removed the javacode from the products that appear on the home page and not the homepage loads fine in IE and Operah.

 

The problem is I really need those Java tabs on my products, as it allows me to describe products better.

 

the code that i placed in the product info is as follows:

 

<div class="tab-page" id="tab-pane-1">

<script type="text/javascript">
var tabPane1 = new WebFXTabPane( document.getElementById( "tab-pane-1" ) );
</script>

  <div class="tab-page" id="tab-page-1">
  <h2 class="tab">Overview</h2>

  <script type="text/javascript">
  tabPane1.addTabPage( document.getElementById( "tab-page-1" ) );
  </script>


The Basic VoIP Desk Phone boasts an impressive feature set at a budget-pleasing price. Users benefit from the feature rich button interface to efficiently perform everyday business tasks.
<p>
The Device is easy to manage and includes a number of Management Tools for large Scale deployment.

  </div>

  <div class="tab-page" id="tab-page-2">
  <h2 class="tab">Features</h2>

  <script type="text/javascript">
  tabPane1.addTabPage( document.getElementById( "tab-page-2" ) );
  </script>

..
  </div>

  <div class="tab-page" id="tab-page-2">
  <h2 class="tab">Specifications</h2>

  <script type="text/javascript">
  tabPane1.addTabPage( document.getElementById( "tab-page-2" ) );
  </script>

..

  </div>

</div>

<!-- tab pane closed -->

<script type="text/javascript">
setupAllTabs();
</script>

 

and directly in the product_info.php page just under the CSS include i have the following:

<!-- Begin tab pane //-->
<script type="text/javascript" src="includes/tabs/webfxlayout.js"></script>
<link id="luna-tab-style-sheet" type="text/css" rel="stylesheet" href="includes/tabs/tabpane.css" />
<script type="text/javascript" src="includes/tabs/tabpane.js"></script>
<!-- End tab pane //-->

 

the tabs that you see in my product info pages are from this site http://webfx.eae.net/dhtml/tabpane/tabpane.html

 

the really STRANGE THING is the tabs work fine on IE when inside pages are viewed, but the homepage crashes if any product with these tabs are located on the homepage.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...