Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Japanese Language Installation


LaurieGudnason

Recommended Posts

HELP!

The contribution does not have instructions in the read me file. I have installed it and obviously I need to edit header_top.php in order to get it to work. I am on version 2.2

Here is the error message I'm getting when I select Japanese language.

 

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /home/edges2/public_html/includes/application_top.php on line 285

 

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /home/edges2/public_html/includes/application_top.php on line 285

 

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/edges2/public_html/includes/application_top.php on line 285.

 

I would appreciate any help on getting this corrected. I need to install Japanese language on several websites. I would also consider paying for assistance!

 

Thanks

laurie

Link to comment
Share on other sites

Hello Laurie,

Adding Japanese is not the biggest of problems. making shipping modules and email encodings work correctly is. So far the official release is version R7 at http://sourceforge.jp/projects/tep-j/files...se_id=3606#3606.

This is built on the milestone1 version so some of the latest contributions will not work. If you read Japanese you will find help at http://lists.sourceforge.jp/mailman/listinfo/tep-j-general. Are you in Japan? If not, you can get away without using the shipping modules for Japan and only use the language files found in the ms1 version. Be sure to use an editor that can handle Japanese EUC-JP encoding (or your web browser set to euc) when saving any file with Japanese in it.

Any problems, you may email me as I don't have time to read the forums much anymore. Good Luck.

[email protected]

Link to comment
Share on other sites

Laurie- It looks as if the file japanese.php is missing from /catalog/includes/languages. Get the ms1 (R7) version from the link below and copy the all Japanese language files to your version (both adamin and catalog). Then go into your administration panel and select localizations/languages and see that Japanese exists

Link to comment
Share on other sites

Hello Laurie,

Adding Japanese is not the biggest of problems. making shipping modules and email encodings work correctly is. So far the official release is version R7 at http://sourceforge.jp/projects/tep-j/files...se_id=3606#3606.

This is built on the milestone1 version so some of the latest contributions will not work. If you read Japanese you will find help at http://lists.sourceforge.jp/mailman/listinfo/tep-j-general. Are you in Japan? If not, you can get away without using the shipping modules for Japan and only use the language files found in the ms1 version. Be sure to use an editor that can handle Japanese EUC-JP encoding (or your web browser set to euc) when saving any file with Japanese in it.

Any problems, you may email me as I don't have time to read the forums much anymore. Good Luck.

[email protected]

 

Thanks for the reply. I am in the USA. I don't read japanese. Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...