Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

buttons missing ??


stirnpanzer

Recommended Posts

Check you /includes/configure.php file. You, most likely, are defining your includes directory improperly. It should be.

define('DIR_WS_INCLUDES', 'includes/'); with no leading '/'. While you are there, check the others as well.

Link to comment
Share on other sites

Check you /includes/configure.php file. You, most likely, are defining your includes directory improperly. It should be.

define('DIR_WS_INCLUDES', 'includes/'); with no leading '/'. While you are there, check the others as well.

 

The only leading "/" are on the catalog, if i remove them then it really screws it up... see my configure.php file....

 

 

define('HTTP_SERVER', 'http://localhost'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'localhost');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', 'c:/program files/apache group/apache/htdocs/catalog');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'root');

define('DB_SERVER_PASSWORD', '******');

define('DB_DATABASE', 'dbname');

define('USE_PCONNECT', 'true'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

Link to comment
Share on other sites

The only difference I see comparing mine to yours is the image directory. My define statements indicates a leading '/'. If your other images are display, then this is not an issue. You are running your locally, so there are some difference inherent in that, and I don't know how that will effect it. One other difference, could be a specific local host setting, but I have:

define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME'])); instead of a path. I have never set up a store on local host, so I don't know about that.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...