Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Whats wrong with my site?


mainframe

Recommended Posts

Well, first of all, the messages are kind of important. Your certificate is expired, and it doesn't belong to you. If its shared SSL, then tell your host that they need to renew it. I can't help you with the images not loading, its probably a configuration problem.

David Amherst

Link to comment
Share on other sites

Set the first two lines in /includes/configure.php

 

exactly the same for now:

 

define('HTTP_SERVER', 'http://www.slot-tastic.co.uk'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'http://www.slot-tastic.co.uk'); // eg, https://localhost - should not be empty for productive servers

 

Your server is acting a little wonky, it's not unusual.

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

Double check your work, it's lost the database log in details,

 

Make sure you saved the file in the correct place. Check to see if you've got a second configure.php file in includes/local. If you find one rename it but make sure all the settings in the primary one are correct.

 

What are you using as an editor?

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

Right, It was annoying me so Ive done a fresh reinstall.

 

My space provider says that server doesnt support SSL. is this why its not working?

Not really.

 

View the page source, you'll see this near the top

 

<html dir="LTR" lang="en">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

<title>Slot-Tastic</title>

<base href="https://slot-tastic.co.uk/">

 

That means the server is asserting on for https. It's a pretty common problem.

 

The quick and dirty way to solve the problem is to set the two server lines the same as I suggested above. I don't know where you screwed up before.

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

errr...

 

You really did a new install. I hope you don't mind that you've wiped out the work you'd already done.

 

Fresh installs are very seldom the best solution, especially for simple problems.

 

If you're going to start from scratch you'd be better off downloading the most recent version (051113) from the download section here. It has many improvements and fixes.

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...