Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Warning: I am able to write to the configuration file:


Guest

Recommended Posts

When I go to look at my online catalogue.

 

I am getting "Warning: I am able to write to the configuration file: /home/<my username>/public_html/store/includes/configure.php. This is a potential security risk - please set the right user permissions on this file."

It is writen in pink on the top of the screen. It suggest that the permissions are set inccorectly however when i have tried to change these the store no longer worked at all... What is the correct permission setting, and what can I do to fix the error?

Link to comment
Share on other sites

When I go to look at my online catalogue.

 

I am getting "Warning: I am able to write to the configuration file: /home/<my username>/public_html/store/includes/configure.php. This is a potential security risk - please set the right user permissions on this file."

It is writen in pink on the top of the screen. It suggest that the permissions are set inccorectly however when i have tried to change these the store no longer worked at all... What is the correct permission setting, and what can I do to fix the error?

 

 

I have almost the same problem, exept that it is impossible to change chmod settings to 444, it goes back to 644.

Link to comment
Share on other sites

When I go to look at my online catalogue.

 

I am getting "Warning: I am able to write to the configuration file: /home/<my username>/public_html/store/includes/configure.php. This is a potential security risk - please set the right user permissions on this file."

It is writen in pink on the top of the screen. It suggest that the permissions are set inccorectly however when i have tried to change these the store no longer worked at all... What is the correct permission setting, and what can I do to fix the error?

 

What permissions did you try that made your store not work??

 

url??

 

Have you tried both 644 and 444

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

What permissions did you try that made your store not work??

 

url??

 

Have you tried both 644 and 444

 

 

Sorry it took me a while to get back to you, I have tried both 644 and 444 when I try to open the page I get

Forbidden

You don't have permission to access <site> on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

heh, I don't know what that means either... <laughs>

Hope you guys can help,

Thanks

Link to comment
Share on other sites

  • 2 years later...

I'm having the same problem.. odd thing is that I didn't used to have that warning.. all of a sudden it appeared.

 

I tried changing both config files in admin and in includes..to 444 ..but they change back to 644 ..which someone else said should fix it..

but I still get the warning!!

 

Any suggestions??

Link to comment
Share on other sites

I have almost the same problem, exept that it is impossible to change chmod settings to 444, it goes back to 644.

 

I was having the same problem. I used FTP to change the permissions from 644 to 444, but it changed itself back to 644 when I exited.

 

I solved this by going to cpanel - file manager and changing permissions there.

 

Hope this helps...

-sam in montana

Link to comment
Share on other sites

I was having the same problem. I used FTP to change the permissions from 644 to 444, but it changed itself back to 644 when I exited.

 

I solved this by going to cpanel - file manager and changing permissions there.

 

Hope this helps...

-sam in montana

 

I had the same problem when using an FTP Client. My host was rejecting it. I instead used the file manager through my hosting company and was able to get it to work properly.

 

Just a thought.

 

Clint

Link to comment
Share on other sites

Hi

 

Whos are your hosts?

 

I have my own hosting ,but the servers are with eliterwebservers who are having a server problem at the moment, so all my osc sites display this error message.

 

I have been assured that techs are trying to sort this out.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...