Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

no payment module, no backups, no shipping.......


simeonfeng

Recommended Posts

Help!!!!!!!!!!!!!

I have built the shop 95% successful so far, except some problem in the admin panels. (the online shop is working fine to me)

1. In the modules/payment, shipping and order total has nothing to be installed. I have all the default options when the same shop in my localhost.

2. Tools/backup, the warning sign "Error: Backup directory does not exist. Please set this in configure.php" is shown. But I had created a folder "backups" in the admin folder (777). Why it is not shown?

 

Thanks a lot.....

 

regards.

Link to comment
Share on other sites

Help!!!!!!!!!!!!!

I have built the shop 95% successful so far, except some problem in the admin panels. (the online shop is working fine to me)

1. In the modules/payment, shipping and order total has nothing to be installed. I have all the default options when the same shop in my localhost.

2. Tools/backup, the warning sign "Error: Backup directory does not exist. Please set this in configure.php" is shown. But I had created a folder "backups" in the admin folder (777). Why it is not shown?

 

Thanks a lot.....

 

regards.

 

You should be able to see where osC is looking and chances are it is different from where the files actually are. Make sure that the paths in your admin/includes/configure.php file are correct and match the actual locations.

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

You should be able to see where osC is looking and chances are it is different from where the files actually are. Make sure that the paths in your admin/includes/configure.php file are correct and match the actual locations.

Thank for reply.

 

But it was quite not easy to set this configure.php. Not sure when should put "/mydomain.com/" and when shouldn't. What is the meaning of "absolute path"???

Link to comment
Share on other sites

Thank for reply.

 

But it was quite not easy to set this configure.php. Not sure when should put "/mydomain.com/" and when shouldn't. What is the meaning of "absolute path"???

 

Basically you have two types of paths FS and WS.

 

FS should look something like /home/username/public_html/admin/

 

WS should be a url http://www.yourdomain.com/admin/

 

If your catalog is working correctly you should be able to look at your includes/configure.php file and get an idea of what the path should look like.

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Basically you have two types of paths FS and WS.

 

FS should look something like /home/username/public_html/admin/

 

WS should be a url http://www.yourdomain.com/admin/

 

If your catalog is working correctly you should be able to look at your includes/configure.php file and get an idea of what the path should look like.

 

Hi, ozcsys. I checked the two configure.php and I can not figure out what went wrong. Here is my admin/includes/configure.php:

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://mydomain.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://mydomain.com');

define('HTTPS_CATALOG_SERVER', '');

define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/catalog/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/catalog/'); // absolute path required

define('DIR_FS_CATALOG', '/catalog/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

// define our database connection

define('DB_SERVER', 'mysql7.opentransfer.com'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'myusername');

define('DB_SERVER_PASSWORD', 'password');

define('DB_DATABASE', 'database');

define('USE_PCONNECT', 'false'); // use persisstent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

 

Any thing not properly set? >_<

Link to comment
Share on other sites

Hi, ozcsys. I checked the two configure.php and I can not figure out what went wrong. Here is my admin/includes/configure.php:

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright ? 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://mydomain.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://mydomain.com');

define('HTTPS_CATALOG_SERVER', '');

define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/catalog/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/catalog/'); // absolute path required

define('DIR_FS_CATALOG', '/catalog/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

// define our database connection

define('DB_SERVER', 'mysql7.opentransfer.com'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'myusername');

define('DB_SERVER_PASSWORD', 'password');

define('DB_DATABASE', 'database');

define('USE_PCONNECT', 'false'); // use persisstent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

 

Any thing not properly set? >_<

 

Can anyone help out there?????

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...