Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Why some images(buttons) not displayed?


asic28

Recommended Posts

Hi,

 

Can you one please tell me why some images (icon/buttons) are not being displayed in my browser?

 

I have searched for answers on my hosting company's website but came up empty handed.

 

I purchase an template from Templatemonster and installed it. Everything went well (i.e. no error messages) during the entire installation process.

 

I have uploaded all the files and verified that the images are on the server and are in the correct directory. Images can be displayed on my desktop just fine (they are in gif format).

 

When I tried to display an image directly I got Internal Server Error:

 

===========

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

===========

 

Image attributes have been set to read and execute.

 

To get a better idea of what I meant, just go here: www.xcelgraphix.com/shop/osc

 

You will see that some buttons are not being displayed.

 

Could it be my browser setting that is causing this problem? I am using IE 6.

 

Thanks in advance for your help!

Vi

Link to comment
Share on other sites

It's the .htaccess file in the includes directory. It's meant to keep outsiders from accessing your php files directly but on some servers it blocks the .gif files that live in includes/languages and below.

 

Just rename that file.

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

It's the .htaccess file in the includes directory. It's meant to keep outsiders from accessing your php files directly but on some servers it blocks the .gif files that live in includes/languages and below.

 

Just rename that file.

 

Right on!

 

Thank you so much! Now I am back in business.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...