Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Prices don't appear


dazza05

Recommended Posts

hello i have just mirgrated servers and have reinstalled os commerce on my new server, installation went fine and i restored the backup database file. all products show up fine but the price fails to show up i get a 0 under the price section.

 

the strange thing is that if i choose another currency when the page refreshes the prices show up. but when i click another product link or refresh the same page the prices dissapear again. until the currency is changed again. i know the database is not corrupted and it shows the prices when the currency is refreshed or changed but does not stay like this.

 

i know it works when i repoint the dns back to the old server prices show up no problem.

anyone please help.

 

thanks

 

 

 

:thumbsup:

Link to comment
Share on other sites

Hello There,

 

I'm very very new to this but was having the very same problem. I seem to have fixed it by changing the default currency code to USD, I was trying to us GBP. Hope this helps.

 

have you set the key for "use default language currency" to false in admin?

admin->configuration->mystore

:-)

Monika

 

addicted to writing code ... can't get enough of databases either, LOL!

 

my toolbox: Textpad - Compare and Merge - phpMyAdmin - WS_FTP - Photoshop - How to search the forum

 

Interactive Media Award July 2007 ~ category E-Commerce

my advice on the forum is for free, PMs where you send me work are considered consultation which I charge for ...

Link to comment
Share on other sites

have you set the key for "use default language currency" to false in admin?

admin->configuration->mystore

 

 

hi thanks for your reply

yes i have changed this to false but no difference as i have no other languages. so it shouldnt really be changing.

 

i have how ever found a sort of fix.

 

 

i have found its best not to delete all entries for the sample currencies or products etc as these causes a 1046 error which prevents you from entering another product or currences or any of the other boxes such as specials or reviews. i found this bug fix posted on the os support forums to stop this error is here for anybody interested.

 

http://www.oscommerce.com/forums/index.php?sho...=0entry735503

 

 

it is best not to delete but to edit each entry

 

i found if you replace the USD$ currency the prices return and will now display in your currency when changed in the currency pull down menu.

 

in admin area change your dollar currency to the currency you wish to use. and set as default. but you will need to create a new currency first! the reason you will need to create a new currency first is to allow you to change the default currency (only place i could find to change it)

 

whilst this works it is not the full answer as now i seem to have 2 default euro currencies and os commerce admin will not allow you to delete a default currency unless you have another set as default. but for some reason has allowed two currencies to show as default. so if anyone knows how to solve this quirk let me know. thanks

 

 

 

:thumbsup: >_<

Link to comment
Share on other sites

hi thanks for your reply

yes i have changed this to false but no difference as i have no other languages. so it shouldnt really be changing.

 

i have how ever found a sort of fix.

i have found its best not to delete all entries for the sample currencies or products etc as these causes a 1046 error which prevents you from entering another product or currences or any of the other boxes such as specials or reviews. i found this bug fix posted on the os support forums to stop this error is here for anybody interested.

 

http://www.oscommerce.com/forums/index.php?sho...=0entry735503

it is best not to delete but to edit each entry

 

i found if you replace the USD$ currency the prices return and will now display in your currency when changed in the currency pull down menu.

 

in admin area change your dollar currency to the currency you wish to use. and set as default. but you will need to create a new currency first! the reason you will need to create a new currency first is to allow you to change the default currency (only place i could find to change it)

 

whilst this works it is not the full answer as now i seem to have 2 default euro currencies and os commerce admin will not allow you to delete a default currency unless you have another set as default. but for some reason has allowed two currencies to show as default. so if anyone knows how to solve this quirk let me know. thanks

 

:thumbsup: >_<

 

if it's possible to assign a second default currency, you need to add a check before the insert for this ...

:-)

Monika

 

addicted to writing code ... can't get enough of databases either, LOL!

 

my toolbox: Textpad - Compare and Merge - phpMyAdmin - WS_FTP - Photoshop - How to search the forum

 

Interactive Media Award July 2007 ~ category E-Commerce

my advice on the forum is for free, PMs where you send me work are considered consultation which I charge for ...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...