Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

New Installation But Old DataBase


Platinum Games

Recommended Posts

Hi All,

 

I have changed my hosting and with it came a easy OSC install, but when i installed it, it has created a new DataBase Called platinum_osc1 (in PHPmyAdmin) now i have still got my old database but it is called 'platinumgames_osc. how can i get my old DB to work on my new server space???

 

i understand that i need to change the configure.php files in both Cat & Admin!

 

please help

Thanks in advance!

 

Ben

Link to comment
Share on other sites

You need to change configure.php in includes and admin/includes:

 

define('DB_SERVER', 'yourserver'); //your mysql server

define('DB_SERVER_USERNAME', 'yourusername'); //your old database username

define('DB_SERVER_PASSWORD', 'yourpassword'); //your old database pwd

define('DB_DATABASE', 'yourdbname'); //your old db name i.e. platinumgames_osc

Link to comment
Share on other sites

You need to change configure.php in includes and admin/includes:

 

define('DB_SERVER', 'yourserver'); //your mysql server

define('DB_SERVER_USERNAME', 'yourusername'); //your old database username

define('DB_SERVER_PASSWORD', 'yourpassword'); //your old database pwd

define('DB_DATABASE', 'yourdbname'); //your old db name i.e. platinumgames_osc

 

 

Check!!

 

Now how do i install my sql on the new server??? i ahve the backup files from my current installation of OSC, so how do i install that on the new installation of OSC as they are on 2 different servers???

 

 

=P

Thanks in advance!

 

Ben

Link to comment
Share on other sites

i was just reading another thread....

 

Can i just restore the old SQL file using the ADMIN restore in osc???

 

The reason i ask and not do is that i still have my active store on my old server and my domain is still active there, so the only way for me to see ADMIN panel is to use the host URL:

 

e.g: http://www.host.com/~username/blah/balh/blah

 

now when i get to the restore button it errors out???

 

@ this point i have been copying the url's into the address bar and changing it to http://www.host.com/~username/admin/restore.php (or what ever the files are).

 

Now i can get as far as the spot to upload a SQL.txt file and that is as far as i can go, untill i have my domain changed to new server??? any simple fixes to my silly little problem???

Thanks in advance!

 

Ben

Link to comment
Share on other sites

OK!

 

I changed the ADMIN/Configure.php to work with my host URL path

 

define('HTTP_SERVER', 'http://www.HOSTNAME.us/~USERNAME/admin'); // eg, http://localhost - should not be empty for productive servers

 

now i get a strange message after the restore???

 

 

1146 - Table 'platinum_osc1.configuration' doesn't exist

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

[TEP STOP]

 

 

what is this???

Thanks in advance!

 

Ben

Link to comment
Share on other sites

I've never tried this, but I think you should be able to export your old database into a flat file from your mySQL administration program. Take that flat file and import it into the new database using the new server's mySQL admin program.

 

That's generally how I move from my test machine to my production server (which have differently named databases).

 

Dom

Link to comment
Share on other sites

I've never tried this, but I think you should be able to export your old database into a flat file from your mySQL administration program. Take that flat file and import it into the new database using the new server's mySQL admin program.

 

That's generally how I move from my test machine to my production server (which have differently named databases).

 

Dom

 

 

i tried to export my SQL but IE crashed ?????

Thanks in advance!

 

Ben

Link to comment
Share on other sites

i tried to export my SQL but IE crashed ?????

 

 

i run the SQL file from OSC ADMIN in the PHPMyAdmin and i installed all the data but i still get the following error???

 

 

1146 - Table 'platinum_osc1.configuration' doesn't exist

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

[TEP STOP]

 

 

How can this be fixed??

Thanks in advance!

 

Ben

Link to comment
Share on other sites

Sorry to bump but i need to fix this problem,

 

 

1146 - Table 'platinum_osc1.configuration' doesn't exist

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

[TEP STOP]

 

 

Any help???

Thanks in advance!

 

Ben

Link to comment
Share on other sites

Sorry to bump but i need to fix this problem,

1146 - Table 'platinum_osc1.configuration' doesn't exist

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

[TEP STOP]

Any help???

 

Sorry to ask again guys......Any ideas?

Thanks in advance!

 

Ben

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...