Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Incomplete installation, does not follow of step 2, administration?


Eggun

Recommended Posts

It has passed me exactly what to a companion:

 

I am trying to install osCommerce in my local equipment and does not only advance in the second screen of the installation, where it asks if catalog wishes to concern the BD and if it wants automatic configuration. I give click in continuing and nothing, does absolutely nothing, I am something disappointed since the PHP-Nuke I installed in 10 minutes and without no problema.

 

osCommerce, runing in local.

 

The difference, is that I am trying it to do in Linux, a Fedora Core 4, and have: version 5,0,4 of php, 2,0,54 of apache, and 4,1,11 of mysql. The permissions for the files are (a+rwx, osea 777, for all the directories, and a+rw, osea 666, for all the files, except configure.php of include/and admin/include, that has 777)

 

I created a virtual servant (perfectly working) with httpd, in/var/www/html/oscom, where this

catalog/

extra/

CHANGELOG

LICENSE...

 

In the directory catalog, I hard created a symbolic connection to the style: ln - sf../catalog

 

I put myself in phpMyAdmin, and concerned bbdd of manual form to the data base ' database' of /catalog/install/oscommerce.sql, that I did, creates the usuary apache, and I assigned to the permissions in bbdd mysql to him, and put him all the privileges to bbddd 'database' and all the privileges to the user 'apache' except the one of SuperUser, later I went to /catalog/includes/configure.php and I left such asi it

 

...
define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'apache');
 define('DB_SERVER_PASSWORD', 'password');
 define('DB_DATABASE', 'database');
 define('USE_PCONNECT', 'true'); // use persistent connections?
 define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'
?>

 

Previously I modified the file/etc/php.ini and modifies

 

; You should do your best to write your scripts so that they do not require
; register_globals to be on;  Using form variables as globals can easily lead
; to possible security problems, if the code is not very well thought of.
register_globals = On

 

(and thus, already it works), but the installation did not go... He is peculiar, it wanted to ask if it is normal that kitchen boys, with the mouse in any image, and put: Not found! To continue In order to finalize, I went to the file: and I left asi it

...
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

// define our database connection
 define('DB_SERVER', 'localhost');
 define('DB_SERVER_USERNAME', 'apache');
 define('DB_SERVER_PASSWORD', 'password');
 define('DB_DATABASE', 'database');
 define('USE_PCONNECT', 'true');
 define('STORE_SESSIONS', '');
?>

 

 

and thus, admin, is seen him, but it does not work, thorn to form things, and it does not publish anything, does not make any work when I give the buttons

 

It is necessary to form the one of the Cookies How, I must make the installation How if it does not leave me? I must update some package of the Fedora?

 

Excuseme for my bad English.

Link to comment
Share on other sites

I am also running on FC4 with the same specs and have come up with the same problem. I don't know where to look. I also run tikiwiki on the server which works fine. In OScommerce though I can't load any of the screens. The address in the browser is called correctly, but the page concerned doesn't load.

 

This started in the install procedure, so I manually installed OSC. Then once installed, I tried to edit the store properties and it wont let me edit any of the data.

 

Any suggestions as to where the problem may be would be aqppreciated.

Link to comment
Share on other sites

Please HELP US!!!!

 

The Solutions, is here, searching...

 

We must to write /etc/php.ini, this code:

; You should do your best to write your scripts so that they do not require
; register_globals to be on;  Using form variables as globals can easily lead
; to possible security problems, if the code is not very well thought of.
[b]register_globals = On[/b]

; Whether or not to register the old-style input arrays, HTTP_GET_VARS
; and friends.  If you're not using them, it's recommended to turn them off,
; for performance reasons.
[b]register_long_arrays = On[/b]

 

Very important to put on, register_long_arrays = On

Link to comment
Share on other sites

  • 2 weeks later...
Seems to be working. Thanks very much.

 

I had set

 

register_globals = On

 

but not the

 

register_long_arrays = On

 

Hopefully somebody else can learn fromour mistakes... happy trading

 

Maarten

 

I had to go through fault finding for this problem last week.

 

You should have 'register_globals = off' in your main php.ini file for security reasons.

 

However, osCommerce requires access to these for install. So they may be set to 'on' in one of two ways;

 

1) In a php.ini file containing the line 'register_globals = 1', and saved in your 'catalogs' root folder.

 

2) you can edit the last lines of the .htaccess file in your 'catalog' folder from this;

 

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

 

To This;

 

<IfModule mod_php5.c>

# php_value session.use_trans_sid 0

php_value register_globals 1

</IfModule>

 

(Note that the numbers have changed also, Although off, osCommerce .htaccess file is set to php4 by default, Also do NOT delete little squares that show up in Notepad, these are carriage return (new line) characters!).

 

Secondly, PHP4 and PHP5 use different methods for Global Variables, PHP5 uses SuperGlobals, something which osCommerce2.2 doesn't take advantage of.

 

Therefor, if using PHP5 you need to set these lines in your httpd.conf file

 

register_long_arrays = on (to Enable osCOmmerce to use $HTTP_*_VARS globally)

 

register_argc_argv = on (to Enable argv and argc variables containing 'Get' information, used rarely)

 

auto_globals_jit = off (because the other two are on)

 

Setting these allows osCommerce to build it's variable arrays and store them globally ready to build the new database prior to import. Without these variable set you are returned to step=2 with NO form information. As the osCommerce script is looking for them to move on to the next step but can't find them it assumes you have not completed this form yet and displays it as if it is the first time.

 

Hope this makes things clearer for you.

 

Cybersilly. :thumbsup:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...