Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

admin and ssl


traveler

Recommended Posts

Hi

I've installed an SSL and all the public pages work fine. The checout, goes under SSL all the way.

But when I get into the admin section, I start with SSL, but as soon as I click any link it returns to the non secure pages.

This is dagerous if I want to read my customers CC.

I have checked this interesting article about the ssl implementation, and everything seems ok.

 

What can be happening?

 

Regards!

Link to comment
Share on other sites

Hi

I've installed an SSL and all the public pages work fine. The checout, goes under SSL all the way.

But when I get into the admin section, I start with SSL, but as soon as I click any link it returns to the non secure pages.

This is dagerous if I want to read my customers CC.

I have checked this interesting article about the ssl implementation, and everything seems ok.

 

What can be happening?

 

Regards!

 

 

When you installed oscommerce and selected to enable ssl, in that page you are asked for the normal

http://server.address.

and then the

https://server.address.

 

When you login to admin the links will refer you back to the http://server.

 

You can overcome this by changing your "admin/includes/configure.php" file.

 

On line 14 you will see the following

 

define('HTTP_SERVER', 'http://your.servername.com'); // eg, http://localhost - should not be empty for productive servers

 

you need to change that to 'https://your.servername.com'

 

Then on line's 19 and 20 you will see this

 

define('DIR_WS_ADMIN', '/jdl/kind2kids/catalog/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/jdl/kind2kids/catalog/admin/'); // absolute pate required

these define the path to your admin folder.

 

Sorry I forgot to mention that these have only been tested on shared ssl servers.

Link to comment
Share on other sites

When you installed oscommerce and selected to enable ssl, in that page you are asked for the normal

http://server.address.

and then the

https://server.address.

 

When you login to admin the links will refer you back to the http://server.

 

You can overcome this by changing your "admin/includes/configure.php" file.

 

On line 14 you will see the following

 

define('HTTP_SERVER', 'http://your.servername.com'); // eg, http://localhost - should not be empty for productive servers

 

you need to change that to 'https://your.servername.com'

 

Then on line's 19 and 20 you will see this

 

define('DIR_WS_ADMIN', '/jdl/kind2kids/catalog/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/jdl/kind2kids/catalog/admin/'); // absolute pate required

these define the path to your admin folder.

 

Sorry I forgot to mention that these have only been tested on shared ssl servers.

 

 

Thanks a lot it worked like charm.

It works as well with non shared ssl cers.

 

Have a nice day!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...