Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

A few probs


da8iwr

Recommended Posts

I have a few probs here, and i think they are all related

 

This is what i have in my admin config file

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.xxxxxx.co.uk'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://www.xxxxxxx.co.uk');

define('HTTPS_CATALOG_SERVER', '');

define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', 'G:/Domains/xxxxxx/wwwroot/shop/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/shop/admin/'); // absolute path required

define('DIR_FS_ADMIN', 'G:/Domains/xxxxxx/wwwroot/shop/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/shop/'); // absolute path required

define('DIR_FS_CATALOG', 'G:/Domains/xxxxxxx/wwwroot/shop/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

// define our database connection

define('DB_SERVER', 'xxxxxx.co.uk'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'xxxxxx');

define('DB_SERVER_PASSWORD', 'xxxxxx');

define('DB_DATABASE', 'xxxxxx');

define('USE_PCONNECT', 'false'); // use persisstent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

Ok problem one - back ups

 

I have spent hours going through these and other forums trying to work out the reason why even though i have made a backups folder and put it on the server, it still dont like it. I have placed the back up folder in wwwroot/shop/admin/backups/ and it still dont dam well work.

 

Problem Two

Is the languages, every time i try to loginto the languages, it says

Warning: dir(G:/Domains/xxxxxx.co.uk/wwwroot/shop/includes/languages/english): failed to open dir: Invalid argument in E:\Domains\spot-ontv.co.uk\wwwroot\shop\admin\define_language.php on line 152

 

Problem three

Warning: dir(G:/Domains/spot-ontv.co.uk/wwwroot/shop/): failed to open dir: Invalid argument in E:\Domains\spot-ontv.co.uk\wwwroot\shop\admin\file_manager.php on line 178

 

Fatal error: Call to a member function on a non-object in E:\Domains\spot-ontv.co.uk\wwwroot\shop\admin\file_manager.php on line 179

 

Problem Four

is the payment modules, none are listed even though there are loads in the directory.

 

I found in this forum this link http://www.oscommerce.com/forums/index.php?showtopic=129064&hl= but really dont understand it, and it seams this person had almost identical probs. So i think what ever they did to fix it, is what i have.

 

I really need help as i have spent hours goin thorugh this forum and cant find any way to fix this problem

Cheers

Link to comment
Share on other sites

Your article tells you whats wrong:

 

Problem Two

Is the languages, every time i try to loginto the languages, it says

Warning: dir(G:/Domains/xxxxxx.co.uk/wwwroot/shop/includes/languages/english): failed to open dir: Invalid argument in E:\Domains\spot-ontv.co.uk\wwwroot\shop\admin\define_language.php on line 152

 

The last line shows the running script is on the E:\ drive, but the Warning is telling you its looking for a language directory on the G:\ drive.

 

You likely just need to fix up the paths that refer to G so they point to E.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...