Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SSL check issue


vlad_bel

Recommended Posts

I have installed osc on the shared host with goDaddy and then bought their ssl for my domain name.

ssl works ok, unfortunately not for osc. Not for catalog directory that is in my case estore. Please check it out and see the page statement which proves that something wrong is there:

https://www.yarnbow.com/estore/ssl_check.php

Just don?t leave me alone, guys.

Big thanks,

-vlad

Link to comment
Share on other sites

OK, I can go to your store and click on My Account and it works as expected for me. Is this not happening for you?

 

Here is a good place to start when troubleshooting SSL issues.

 

Good luck!

 

Thank you for reference, i'll read it thru.

 

It's just strange that my store installation works(!) for you. I hope there is nothing personal about it.

I have tried it from different computers and browsers. I have no padlock in IE and bad padlock in FF.

When i do ssl_check, it reports "We have detected that your browser has generated a different SSL Session ID used throughout our secure pages."

 

Thanks.

Link to comment
Share on other sites

I have tried it from different computers and browsers. I have no padlock in IE and bad padlock in FF.

Oh, yeah, I'm getting that, too. I thought from your initial post that you were getting a 404 or something when you tried to enter the secure area. I'm not a pro at the SSL stuff. Hopefully that thread will point you in the right direction.

Link to comment
Share on other sites

Hopefully that thread will point you in the right direction.

 

O yea, looks like it did. i figured out from the that i should first check the list of "Trusted Root Certification Authorities" in IE options. Then i would see that Starfield Secure Certification Authority is not in that list and most likely would not buy it.

 

But(!) my unexpansive certificate nevertheless works. The issuer is not in browser list but the apparent problem comes up only when the catalog directory visited.

I need to study the thread further.

Link to comment
Share on other sites

Got it.

My images on the catalog pages were not linked thru https but thru http. This did not cause my browsers to warn me though.

I fixed this by replacing http:// with https:// in the first definition of configure.php

define('HTTP_SERVER', 'http://www.yourdomain.com'); // eg, http://localhost - should not be empty for productive servers

 

I am wondering why this problem for everyone installing osc first time by himself has not been fixed yet or supplied with comment addressing that.

Link to comment
Share on other sites

Got it.

My images on the catalog pages were not linked thru https but thru http. This did not cause my browsers to warn me though.

I fixed this by replacing http:// with https:// in the first definition of configure.php

define('HTTP_SERVER', 'http://www.yourdomain.com'); // eg, http://localhost - should not be empty for productive servers

 

I am wondering why this problem for everyone installing osc first time by himself has not been fixed yet or supplied with comment addressing that.

It's been addressed and solved hundreds of times.

 

Yours is not any kind of a solution. You're saying that you're running the store through https constantly?

 

You'll never be indexed by search engines and the site will be slow. Did you work your way all the way through that thread? The correct solution is in there.

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

I did not know where the best solution is, that's right. But i know now how to make experts talking. :)

Thanks

p.s. the fact that this problem has been solved hundred times proves what i was wondering about. The problem addressed in the manual not in the forums. that's what i meant.

Link to comment
Share on other sites

Thank you Alan very much!

As you advised i found your post in the referenced thread, backed up my changes in configure.php, and replaced line 41 in application_top.php with suggested one. Port 443 works out great!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...