Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

how to secure /admin/index.php


newone

Recommended Posts

I went ahead and used the .htaccess file to secure the admin folder and it works great. but when I go to this address www.mysite.com/admin/index.php it promps me for a username and password, if I cancell out of the login, I still get in the admin login page minus some gif, and maybe some of the templet. Am I missing something in the htaccess files? Thanks for your help.

Link to comment
Share on other sites

I think your browser is simply loading the internet cache from when it last visited that page. THat explains why the formatting and pictures are not there.

 

Try emptying your internet cache and then BEFORE logging in, try and access the page. If it still comes up, post here again.

 

To empty cache, if microsoft explorer, go to TOOLS/INTERNET OPTIONS, then select "delete files".

 

Hopefully this will solve your problem:)

 

--Peter

CE PHOENIX SUPPORTER

Support the Project, go PRO and get access to certified add ons

Full-time I am a C-suite executive of a large retail company in Australia. In my spare time, I enjoying learning about web-design.

Download the latest version of CE Phoenix from gitHub here

Link to comment
Share on other sites

I went ahead and used the .htaccess file to secure the admin folder and it works great. but when I go to this address www.mysite.com/admin/index.php it promps me for a username and password, if I cancell out of the login, I still get in the admin login page minus some gif, and maybe some of the templet. Am I missing something in the htaccess files? Thanks for your help.

 

I had the same problem. Dump your cached files.

I can't help you with I.E., but in Firefox it is...

 

Edit --> Preferences --> Privacy --> Cache --> Clear

 

Then try reloading it.

 

If you click cancel you should get something similar to...

 

Authorization Required

 

This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

 

Hope this helps.

Link to comment
Share on other sites

I went ahead and used the .htaccess file to secure the admin folder and it works great. but when I go to this address www.mysite.com/admin/index.php it promps me for a username and password, if I cancell out of the login, I still get in the admin login page minus some gif, and maybe some of the templet. Am I missing something in the htaccess files? Thanks for your help.

 

Easiest way is to hold down Ctrl then jab F5. :thumbsup:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...