Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Moving Site problems


eMagin

Recommended Posts

on changing almost any of the admin options, such as payment, cache etc i get this error

 

Warning: fopen(http://www.hellostamps.com/config_cache/config_cache.php): failed to open stream: HTTP wrapper does not support writeable connections. in /home/stampsd/public_html/catalog/admin/includes/configuration_cache.php on line 38

 

Warning: fwrite(): supplied argument is not a valid stream resource in /home/stampsd/public_html/catalog/admin/includes/configuration_cache.php on line 39

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/stampsd/public_html/catalog/admin/includes/configuration_cache.php on line 40

 

Warning: Cannot modify header information - headers already sent by (output started at /home/stampsd/public_html/catalog/admin/includes/configuration_cache.php:38) in /home/stampsd/public_html/catalog/admin/includes/functions/general.php on line 18

 

hellostamps.com was my old site, the new site is now www.stampsdomain.com

 

 

 

this is my config file

 

define('HTTP_SERVER', 'http://www.stampsdomain.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.stampsdomain.com');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/stampsd/public_html/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

Link to comment
Share on other sites

The information you provided looks like it's from: catalog/includes/configure.php

 

If it is, you should do the following.

 

change

define('HTTP_COOKIE_PATH', '/catalog/');

 

to

define('HTTP_COOKIE_PATH', '/home/stampsd/public_html/catalog/catalog/');

 

 

Also, in your Admin > Configuration turn Cache settings to 'false'.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...