Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

php.ini File - Fatal.Error - How to fix??


admark

Recommended Posts

Out of the blue, I have this fatal error popping up on my oscommerce site.

 

The home page is fine, but it is not a part of the oscommerce site. When you click to enter the OsCommerce site. I get this

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

And I can't get in to any of my oscommerce files.

 

 

 

Any help is appreciated.

 

Thanks in Advance!

Link to comment
Share on other sites

Not sure I understand what I'm changing.

 

if (function_exists('ini_get')) {

ini_get('register_globals') or exit('FATAL ERROR: register_globals is disabled in php.ini, please enable it!');

}

 

That is the code in application_top.php, what do I change? Sorry I am not as fluent with php as I should be.

 

Thanks

 

You have to set register_globals on.

I would make a change in catalog/includes/application_top.php and set there with

ini_set('register_globals', 1)

INI-Value to true.

 

Good luck

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...