Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Upgrade - reported problems in database


hobbyfly

Recommended Posts

I made an upgrade in the store using the latest version (osCommerce 2.2 Milestone 2 051112 Update Released).

 

After the database upgrade I become the message:

"......

Status: Update Complete!

 

 

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/httpd/html/uol2356anx.plugin.com.br/html/testes/catalog/install/includes/functions/database.php on line 45

 

(message below = 7 times)....

 

The database upgrade procedure was successful!

..."

 

 

When I start the catalog become a message:

"......

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'EXPECTED_PRODUCTS_SORT limit 5' at line 1

 

select p.products_id, pd.products_name, products_date_available as date_expected from products p, products_description pd where to_days(products_date_available) >= to_days(now()) and p.products_id = pd.products_id and pd.language_id = '4' order by EXPECTED_PRODUCTS_FIELD EXPECTED_PRODUCTS_SORT limit 5

 

[TEP STOP]

....."

 

 

The version of database is MySQL 4.1.12-standard-log

 

What can I do to fix the problem?

 

Hobbyfly

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...