Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Paypal IPN V1.1 email & cart issue


Bozmium

Recommended Posts

Greets forum,

 

Ok i so i took the plunge and am trying to integrate the Paypal IPN V1.1 into Aus based osCommerce store. I have installed and configured it and got it working reasonably with a minimum of fuss - HOWEVER.

 

Two serious issues remain to be resolved.

 

1. As many people seem to experience - i am not getting my store emails sent out.

2. My shopping cart does not reset. When the client comes back to the checkout success page the items ordered are still sitting in their cart. Probably just a matter of adding

 

$cart->reset(true);

 

to the checkout success page, but wanted to know if this is the correct method of tackling it.

 

Once i have these two issues sorted im home and hosed - would love some info or a slap in the right direction if they have already been sorted.

 

Cheers & thanks.

And with a 9 in 10 search rate success the no.1 returned Oscommerce forum hit:

"The administrator has enabled flood control - please try again in 30 seconds."

 

Never fails.

 

Every time.

Link to comment
Share on other sites

Ok figured it out - thought id knock it up here for anyone having similar issues - which seems to be quite a few.

 

In the paypal_ipn.php file you will find a parameter line:

 

$parameters['return'] = tep_href_link('/checkout_success.php');

 

around line 331. This is what sets your return url for the paypal IPN when the customer confirms and is sent back to your shop.

 

change checkout_success to checkout_process if you are having the same sort of email probs and see how you go. May not make a difference for all.

 

Also rectified the cart not resetting and the stock not being decremented.

 

Just for interest for those confused - no return url or IPN url needs to be specified in the Paypal profile preferences - you can leave it empty.

 

This contrib appears to work smashingly well with all IPN updates being received - thanks to the original authors.

And with a 9 in 10 search rate success the no.1 returned Oscommerce forum hit:

"The administrator has enabled flood control - please try again in 30 seconds."

 

Never fails.

 

Every time.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...