Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

main(includes/languages/.php): failed to open stream: No such file or directory


komc

Recommended Posts

Dear members,

 

I have recently learnt to upload oscommerce to the website from my PC which is successfully installed (in PC). There are errors appearing on the opening screen when I typed the www.xxx.com.hk as below:

 

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /home/giftme/domains/giftmemore.com.hk/public_html/catalog/includes/application_top.php on line 288

 

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/local/lib/php') in /home/giftme/domains/giftmemore.com.hk/public_html/catalog/includes/application_top.php on line 288

 

May I have your opinion to correct the errors.

 

Thank you in advance.

 

komc

Hong Kong

Link to comment
Share on other sites

Hi

 

the error means you cannot open the file oeither becasue it does not exist.

goto application_top.php on line 288 and see what the file is.

 

Chances are the DIR LANGUAGES setting in the configuration file is incorrect.

Check this setting is correct. You need a directory for the language files to be found so if the site is in mandarin then you neeed a set of mandarin language files.

 

If it is a fresh install then the error is more than likely in the configuration file on the catalog and most propbably on the admin side too

 

I hope this helps.

 

Regards

Sean

 

Dear members,

 

I have recently learnt to upload oscommerce to the website from my PC which is successfully installed (in PC). There are errors appearing on the opening screen when I typed the www.xxx.com.hk as below:

 

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /home/giftme/domains/giftmemore.com.hk/public_html/catalog/includes/application_top.php on line 288

 

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/local/lib/php') in /home/giftme/domains/giftmemore.com.hk/public_html/catalog/includes/application_top.php on line 288

 

May I have your opinion to correct the errors.

 

Thank you in advance.

 

komc

Hong Kong

free is often better than cheap

Link to comment
Share on other sites

Hi

 

the error means you cannot open the file oeither becasue it does not exist.

goto application_top.php on line 288 and see what the file is.

 

Chances are the DIR LANGUAGES setting in the configuration file is incorrect.

Check this setting is correct. You need a directory for the language files to be found so if the site is in mandarin then you neeed a set of mandarin language files.

 

If it is a fresh install then the error is more than likely in the configuration file on the catalog and most propbably on the admin side too

 

I hope this helps.

 

Regards

Sean

 

 

Hi Sean,

 

Now, I recognise where I went wrong. During the time of installation, I overlooked a step of linking the path to chinese database :

 

/catalog/install/tchinese.sql

 

After going through all steps of installation, this may be the reason as the installation is successfull now.

 

Thanks for your kind assistance and guide.

 

komc

Hong Kong

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...