Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Product images not showing on site.


Recommended Posts

Okay, I installed the cart on a live site, it was to be secondary, until I got the catalog filled up. The live site uses index.html, so I would just go to using index.php when the catalog was loaded. The old site was being used, so had to stay live until the switch.


Anyways when uploading the new cart, I ran into a problem, I already had a file named header.php, which still was being used. So I renamed the new carts header.php to header1.php. I then used search and replace to change the carts files, and uploaded the changes. Dumb me did'nt realize I uploaded the configure.php file over the one created by install on the server.


Long story short I got everything working except one problem. I can add product images and they show in the admin, they also get uploaded to the server. Problem is, the site does not show the image. The images are being stored in /catalog/images/ on the server. When I check the source code for the cart pages, they are trying to load the images from only "images/filename.jgp", which is why of course it shows a broken image, trying to load it from the wrong directory.


I want to keep the images where they are, in /catalog/images/ , so what do I change in the configure.php page to do this? To load the images as /catalog/images/filename.jpg instead of /images/filename.jpg ?


This is driving me crazy. Any help would be GREATLY appreciated.


Thanks in advance.



Link to comment
Share on other sites

I feel like a real idiot. BAd as it sounds I keep editing and messing with the configure.php in the admin/includes/ , gee it's no wonder the site was'nt showing the changes. Might help if I edited the right file.


Course it was'nt the end of my being stupid. I edited the correct file this time, but once again, without thinking, I uploaded that one to overwrite the one changed by the install. It seems like one thing afer another sometimes..:)


But I got everything working so far. I'll have to double check the other settings in the site configure.php, not sure if the other settings are right. If any one has a chance, could they double check what I should have for these:


define('HTTP_COOKIE_DOMAIN', 'http://www.mysite.com');

define('HTTPS_COOKIE_DOMAIN', 'https://www.mysite.com');

define('HTTP_COOKIE_PATH', '');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '');

define('DIR_WS_HTTPS_CATALOG', '');


I think I have the cookie domain settings right, not sure about the others, what should be there. The rest should be defualts, though I did correct the db connection at the bottom.


Thanks for the heads up yesudo! I might have spent even more time being stupid. Seems like its always something so simple and easy. You pointed me in the right direction and got my problem fixed. Now to fix my other mess up and I'm set..:)



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...