Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Problem getting downloads working


Recommended Posts

I have installed downloads controller, set everything up to allow downloads and still don't get download links. For testing purposes I am using one file for all products (filename text.pdf, located in catalog/download) and a cost of $0.00. After a number of days of troubleshooting, I have found that no records are inserted into the orders_products_downloads table.

I have searched the forums for solutions and tried the ones that were applicable, still no luck.

If anyone has any suggestions, please let me know.


Here is the setup:



define('HTTP_COOKIE_DOMAIN', '.localhost');

define('HTTPS_COOKIE_DOMAIN', '.localhost');

define('HTTP_COOKIE_PATH', '/cpiaweb//catalog/');

define('HTTPS_COOKIE_PATH', '/cpiaweb//catalog/');

define('DIR_WS_HTTP_CATALOG', '/cpiaweb/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/cpiaweb/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');


define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');


define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . '/download/');



In the Admin, Downloads section:

Enable download true

Download by redirect false (have also tried with redirect on)

Expiry delay (days) 0

Maximum number of downloads 3

Downloads Controller Update Status Value 4

Downloads Controller Download on hold message <BR><font color="FF0000">NOTE: Downloads are not available until payment has been confirmed</font>

Downloads Controller Order Status Value 2


Added a product option named "download" and made it "yes" for all products.


I get the Headers for Product Download, but no links or text.

This is the only thing keeping me from going live

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...