Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

session.php error messages after installation


Broadsword

Recommended Posts

I have installed osCommerce on my server but when configuring keep getting these error messages at the top of the screen. I have tried altering the permissions of a few files as sugested in the installation documentation but it makes no difference.

 

Can anyone please suggest what i need to do? Any help would be much appreciated.

 

Thanks

 

 

The error messages are as below (with my real site details replaced with 'mywebsite' and 'myshop')

 

 

 

Warning: session_save_path(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/home/mywebsite/public_html) in /home/mywebsite/public_html/myshop/catalog/admin/includes/functions/sessions.php on line 110

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/mywebsite/public_html/myshop/catalog/admin/includes/functions/sessions.php:110) in /home/ywebsite/public_html/myshop/catalog/admin/includes/functions/sessions.php on line 67

Link to comment
Share on other sites

The second error is caused by the first. Cure the first and the second goes away.

 

Unfortunately you are hosted on a server running PHP in Safe Mode. There are two things you can do:

 

1. Edit both configure.php files to read 'mysql' where indicated on the last line of each. This stores sessions in the database and not in files and would normally make the error go away (see 2).

 

2. The error may not go away with PHP being run in Safe Mode, as it still expects the 'tmp' folder to be within the correct path - and only God and your hosting company (and maybe not even the hosting company) knows what this should be. You can try creating a folder called 'tmp' in the root of your domain and setting the path to it (in your osC admin panel) from /tmp to tmp/ But if this doesn't work then you may have to use the full path (of which this is only an example)

/var/www/html/tmp/

 

If none of the above work - move hosts, because PHP running in Safe Mode will cause you other problems you have't come across yet.

 

Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...