Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

FATAL ERROR: register_globals is disabled in php.i


pidz

Recommended Posts

i just uploaded OScommerce to my new .com and i'm wondering on how to fix my 1st problem. Once uploaded to my http://*.*/catalog/ i go on it and it gives me an error: FATAL ERROR: register_globals is disabled in php.ini, please enable it!

So i'm asking myself how because i don't find this file in Catalog folder. I also whant to know where do i change the permission 777 775??? pl help thanks

Link to comment
Share on other sites

That option needs to be set by the host. If they won't set it for you, then add this line to a new file and save the file as .htaccess

php_value register_globals 1

If you already have such a file, just add that line to it. Place the file in the root directory and it should work.

 

Permissions are specific to each file/directory so you need to change them by right clicking on them in your ftp program and selcting properties or chmod. You may also have an option to set them via your hsots control panel.

 

jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

If this is a new site and you haven't modified any of those files with contributions then the answer is 'Yes'.

 

If you have already modified those files then you will have to use the original Register Globals Patch contribution, where all instructions are pasted line by line and page by page (takes a lot longer)

 

Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...