Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

On checkout it takes me to login page


Guest

Recommended Posts

Hi! I've searched the forums and found no solution, though I'm sure it's there somewhere...So, it's me again! :)

 

The problem is that when I go to checkout

 

 

 

 

9after logging in and putting in the basket a product) it takes me to login page, saying that my visitors cart will be added to members cart if I login.

Same thing (almost) when i click from any other page on home. It takes me to the index but I'm not logged in anymore. This would be a BIIIG turnoff for the client, so is any one willing to help?

 

My site: www.muccelmic.com

 

Thanks in advance!

Link to comment
Share on other sites

You have a serious problem with your sessions. Can you post the contents of your includes/configure.php file (blank out the database connection bit for security!!)

 

When I clicked around your store, I visited 9 pages and generated 3 different session id's. Even if I created an account, I would not be able to use it - checkout is a minimum 5 page process and no way would a customer get from start to finish in the same session based on what I experienced!

 

On the bright side, the fix is normally dead simple - post that file and we'll sort it out!

Please note - if I have suggested a contrib above, it doesnt mean it will work! Most of the contribs are not ones I've used, but may be useful for your particular problem....

Have you tried a refined search? Chances are your problem has already been dealt with elsewhere on the forums.....

if (stumped == true) {

return(square_one($start_over)

} else {

$random_query = tep_fetch_answer($forum_query)

}

Link to comment
Share on other sites

Thanks for helping me! I had no idea about that, especially since I'm by far no expert. This is my configure.php file.

 

 

 

<?php

/*

$Id: configure.php,v 1.14 2003/07/09 01:15:48 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://muccelmic.com');

define('HTTPS_SERVER', 'https://muccelmic.com');

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'http://muccelmic.com');

define('HTTPS_COOKIE_DOMAIN', 'https://muccelmic.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/muccelmic/');

define('DIR_WS_HTTPS_CATALOG', '/muccelmic/');

define('DIR_WS_IMAGES', '/muccelmic/images/');

define('DIR_WS_ICONS', '/muccelmic/icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', '**********');

define('DB_SERVER_PASSWORD', '***********');

define('DB_DATABASE', '******');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', 'mysql');

?>

Link to comment
Share on other sites

Try this:

define('HTTP_COOKIE_DOMAIN', '.muccelmic.com');
define('HTTPS_COOKIE_DOMAIN', '.muccelmic.com');

Please note - if I have suggested a contrib above, it doesnt mean it will work! Most of the contribs are not ones I've used, but may be useful for your particular problem....

Have you tried a refined search? Chances are your problem has already been dealt with elsewhere on the forums.....

if (stumped == true) {

return(square_one($start_over)

} else {

$random_query = tep_fetch_answer($forum_query)

}

Link to comment
Share on other sites

Your problem is that you don't have a full ssl certificate, but your configure.php file is set up as though you have one. Your file should read like this:

 

define('HTTP_SERVER', 'http://muccelmic.com');

define('HTTPS_SERVER', '');

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'muccelmic.com');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/muccelmic/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', 'icons/');

 

Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...