Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Pre-Installation Setup Problem?


Recommended Posts

I am running Mandriva Linux, looking to set up a localhost system to work with. I asked the Mandriva urpm to install osCommerce rpm (binary) whereupon, urpm properly installed Apache, MySQL, osCommerce, etc. Apache and MySQL are running, plus PhP 4 is on the system.


I have never used SQL or MySQL before. I suspect I have done something wrong in setting up my blank database and assigning a user.


When I point my browser at localhost/osCommerce I get through the first two pages of the osCommerce Installation Procedure. Thus, I have just entered Database Server, UserName, Password, Database Name, Persistent Connection, and Session Storage (database), and hit continue. The next page starts to load and dies displaying maybe a sixth of the page and the reast is just white. I can see the osComerce Banner, and below that in sequence, New Installation and then Database Import, and nothing after that.


I have found two configure.php files, and the binaries had already set them up with 777 permissions. I also tried editing admin/includes/classes/upload.php on line 31 from $this=null; to unset($this); But this had no effect, so changed it back.


I suspect I have done something wrong in setting up my blank database. First on the command line I said: mysql -P 3307 -u root -p mysql

And I got the welcome notice, and then said: create database storedata;

I then exited, because I do not know how to create a user yet from the command line, and so, I used MySqlAdministor to create a lessor user than root, BUT I COULD NOT FIND WHERE ONE ASSIGNS A NEW USER TO A SPECIFIC DATABASE in the tutors I have been reading.


So, when my osCommerce Installation Procedure did not work with the lessor user, I figured it was because I had not yet found out how to assign the lessor user to the database called storedata, so, I decided to use the root name and password that I had used in SQL to create the blank database and try again, and got this same error in the osCommerce Installation Procedure.


So, guys? What am I doing wrong? I really appreciate your help. Thanks! :rolleyes:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...