Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

page_cache 1.5 pb with header_tags


pleymo

Recommended Posts

hello

 

I have install page_cache 1.5

when i load my website for 1 time it's ok when i want to surf on others page i have

this

 

Warning: main(includes/languages//header_tags.php): failed to open stream: No such file or directory in c:\web\www\includes\header_tags.php on line 6

Fatal error: main(): Failed opening required 'includes/languages//header_tags.php' (include_path='.;C:\web\\php\pear\') in c:\web\www\includes\header_tags.php on line 6

 

if i delete cache i can load index page and then it's the same thing error

 

help please :'(

Link to comment
Share on other sites

watch your configuration for this extra slash between languages-header

Warning: main(includes/languages//header_tags.php)

and

'includes/languages//header_tags.php'

Link to comment
Share on other sites

means that langage must be set for page_cache

(before this installation i haven't pble with hearder_tags)

 

The language is not getting set.

 

Warning: main(includes/languages/english/header_tags.php):

 

Around line 264 catalog/includes/application_top.php

 

My osc have somes contribution and application_top.php has change, what must i find in application_top?

 

thanks

Link to comment
Share on other sites

Seems the $language variable in your application_top.php is not initialized but I dont know why. Is english the default you are using?

Link to comment
Share on other sites

Hello

 

Seems the $language variable in your application_top.php is not initialized but I dont know why. Is english the default you are using?

 

No it's french by default, what is the code to inialized $language in appication_top?

 

thanks

Link to comment
Share on other sites

here is the code for the language in application top

// set the language
 if (!tep_session_is_registered('language') || isset($HTTP_GET_VARS['language'])) {
   if (!tep_session_is_registered('language')) {
     tep_session_register('language');
     tep_session_register('languages_id');
   }

   include(DIR_WS_CLASSES . 'language.php');
   $lng = new language();

   if (isset($HTTP_GET_VARS['language']) && tep_not_null($HTTP_GET_VARS['language'])) {
     $lng->set_language($HTTP_GET_VARS['language']);
   } else {
     $lng->get_browser_language();
   }

   $language = $lng->language['directory'];
   $languages_id = $lng->language['id'];
 }

 

and for some reason is not getting set. I presume you have the french language in your admin.

Link to comment
Share on other sites

  • 1 year later...

Having a similar problem as above. Searching finds a few other reports but not any resolution. Installed Page Cache 1.5 and with the contrib enabled I get:

 

Warning: main(includes/languages//header_tags.php): failed to open stream: No such file or directory in /xxx/public_html/catalog/includes/header_tags.php on line 18

Warning: main(includes/languages//header_tags.php): failed to open stream: No such file or directory in /xxx/public_html/catalog/includes/header_tags.php on line 18

Fatal error: main(): Failed opening required 'includes/languages//header_tags.php' (include_path='.:/usr/local/lib/php') in /xxx/public_html/catalog/includes/header_tags.php on line 18

 

I notice the double backslashes languages//header_tags.php but I don't see the double backslashes in any of the files changed by Page Cache or in includes/header_tags.php. My language code in application_top matches the code listed by enigma1. Any help, much appreciated.

Link to comment
Share on other sites

  • 2 weeks later...
Having a similar problem as above. Searching finds a few other reports but not any resolution. Installed Page Cache 1.5 and with the contrib enabled I get:

 

Warning: main(includes/languages//header_tags.php): failed to open stream: No such file or directory in /xxx/public_html/catalog/includes/header_tags.php on line 18

Warning: main(includes/languages//header_tags.php): failed to open stream: No such file or directory in /xxx/public_html/catalog/includes/header_tags.php on line 18

Fatal error: main(): Failed opening required 'includes/languages//header_tags.php' (include_path='.:/usr/local/lib/php') in /xxx/public_html/catalog/includes/header_tags.php on line 18

 

I notice the double backslashes languages//header_tags.php but I don't see the double backslashes in any of the files changed by Page Cache or in includes/header_tags.php. My language code in application_top matches the code listed by enigma1. Any help, much appreciated.

 

Nevermind, fixed. Was a problem with STS.

Link to comment
Share on other sites

Nevermind, fixed. Was a problem with STS.

 

If that is the only time you are getting a double slash, my guess is that it's in the file definition. Check your define statements in both filenames.php

Just between us, remember there are only 10 kinds of people in the world; those who understand binary and those who don't!!

 

Remember, learning is a "do-it-yourself" experience; although, not necessarily a "do-it-BY-yourself" experience.

 

The quickest way to learn is to forget to BACKUP!

Link to comment
Share on other sites

If that is the only time you are getting a double slash, my guess is that it's in the file definition. Check your define statements in both filenames.php

Don't think so, there are no slashes in filenames.php and no changes are made to it during page_cache installation. No changes were made to it to remove STS. Was planning on removing STS any way though, to save on queries.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...