Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

xampp problem


Guest

Recommended Posts

Hi all. I installed xampp on my computer and transferred everything to it from my site, but when i go to localhost/catalog, it gives me this error message:

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'greatgif'@'localhost' (using password: YES) in C:\Program Files\xampp\htdocs\catalog\includes\functions\database.php on line 19

Unable to connect to database server!

What did I do wrong?

Thanks

Laura

Link to comment
Share on other sites

1. Did you start the mysql and php services - they don't start by default.

 

2. Did you set up a password and a new user name via XAMPP's security settings? By default the User Name is root and there is no Password unless you set one up.

 

You're not using your online mysql User Name and Password by any chance? If so, change in the configure.php files.

 

Vger

Link to comment
Share on other sites

1.  Did you start the mysql and php services - they don't start by default.

 

2.  Did you set up a password and a new user name via XAMPP's security settings?  By default the User Name is root and there is no Password unless you set one up.

 

You're not using your online mysql User Name and Password by any chance?  If so, change in the configure.php files.

 

Vger

They are started.......at least when I open the xampp control panel it says that everything is running.

I did not set a username/pass via XAMPP's security settings............i don't even know where those are.......is that the "settings" in the xampp control panel? If so, the user/pass is greyed out, I can't enter anything there.

I have not entered any user/pass for anything........do I need to? I copied the files right from my site, so wouldn't they be set up to "need" my online user/pass for mysql? I don't know if I am understanding this right or not.

Thanks for all your help.

Link to comment
Share on other sites

Not sure if I needed to "move" anything else from my site to my computer..........but what I moved was my database and I moved my "catalog" folder into htdocs........don't know if that will help, or if maybe I did something wrong there.

Thanks!

Link to comment
Share on other sites

In your local installation of osCommerce you need to edit the two configure.php files to use your 'local' User Name and Password for XAMPP. Yur User Name is root and there is no password, so leave this blank.

 

Did you download your online database and install it locally?

 

If not then you need to download a backup, then go to http://localhost/phpmyadmin and create a blank database, then click on that blank database, click on the SQL tab at the top of the page, use the Browse function to locate the downloaded backup of your online database, and then click the 'Go' button. This will import the contents of your online database into your local installation. And the name of the database you enter in your two configure.php files will be the name you used when creating the blank database in phpMyAdmin.

 

Vger

Link to comment
Share on other sites

ok, another problem........lol

I go to localhost/catalog/admin and it comes up with the password thingy and I tried both "root and no password" and my online user/pass for it and neither work.......what do I do to fix this?

Thanks

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...