Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Install ERROR: register_globals


eetc

Recommended Posts

Dear All,

 

I'm a newbie here, I got a error when I try to install OSC,

 

"FATAL ERROR: register_globals is disabled in php.ini, please enable it! "

 

How can I do?

 

where can I find php.ini file?

 

Thanks a lot.

Link to comment
Share on other sites

Hi there,

 

Well I am new at this and got this error aswell :) But because I have knowledge in PHP modification I had some idea of how to fix it.

I take it that you are running this on your local system? If you are not you are going to have to contact your host and ask them to turn "on" the "register_global" option in PHP.

 

Find you PHP directory on your computer. (possibly located in c:\php)

 

Open the directory and look for the file "php.ini" double click to open it.

 

If you are using windows hold CTRL+F and it will bring up a find box. Type this into the box "register_global" without the quotation marks. Then press enter twice.

 

You should then see a line of text that says this - "register_globals = off"

 

All you have to do to get rid of the error is change the work "off" to "on" then save the file and then try installing again.

 

Let me know how you get on with this ok. And I hope it helped. :rolleyes:

 

 

Dear All,

 

I'm a newbie here, I got a error when I try to install OSC,

 

"FATAL ERROR: register_globals is disabled in php.ini, please enable it! "

 

How can I do?

 

where can I find php.ini? file?

 

Thanks a lot.

Link to comment
Share on other sites

Hi Phillracer,

 

Yes, I running this on my local system, Win XP.

 

And I did it as you suggest, but this problem is still in, screen also shows " FATAL ERROR: register_globals is disabled in php.ini, please enable it! "

 

Does my computer can't install OSC? and I install success on another computer.

 

I don't know how to resolve this.

 

Thanks for your kindly reply.

 

 

Hi there,

 

Well I am new at this and got this error aswell :) But because I have knowledge in PHP modification I had some idea of how to fix it.

I take it that you are running this on your local system? If you are not you are going to have to contact your host and ask them to turn "on" the "register_global" option in PHP.

 

Find you PHP directory on your computer. (possibly located in c:\php)

 

Open the directory and look for the file "php.ini" double click to open it.

 

If you are using windows hold CTRL+F and it will bring up a find box. Type this into the box "register_global" without the quotation marks. Then press enter twice.

 

You should then see a line of text that says this - "register_globals = off"

 

All you have to do to get rid of the error is change the work "off" to "on" then save the file and then try installing again.

 

Let me know how you get on with this ok. And I hope it helped. :rolleyes:

Link to comment
Share on other sites

Hi Phillracer,

 

Yes, I running this on my local system, Win XP.

 

And I did it as you suggest, but this problem is still in, screen also shows " FATAL ERROR: register_globals is disabled in php.ini, please enable it! "

 

Does my computer can't install OSC?  and I install success on another computer.

 

I don't know how to resolve this.

 

Thanks for your kindly reply.

 

You must restart your server :-"

 

Matti

Link to comment
Share on other sites

You must restart your server  :-"

 

Matti

 

:) Yeah, ok, can install it now.

 

But It has a problem when I got to the last step. it shows:

 

Warning: fopen(E:/usr/www/catalog/admin/includes/configure.php): failed to open stream: No such file or directory in E:\usr\www\catalog\install\templates\pages\install_7.php on line 259

 

Warning: fputs(): supplied argument is not a valid stream resource in E:\usr\www\catalog\install\templates\pages\install_7.php on line 260

 

Warning: fclose(): supplied argument is not a valid stream resource in E:\usr\www\catalog\install\templates\pages\install_7.php on line 261

 

The configuration was successful!

 

Oh, My God! help me, pls .

Thank you!

Link to comment
Share on other sites

Make sure that the file has write permissions (right click - uncheck 'read only', or make sure you as a user have the correct permissions.)

 

Make sure that your php.ini include_path has .; at the beginning.

 

Matti

Link to comment
Share on other sites

Make sure that the file has write permissions (right click - uncheck 'read only', or make sure you as a user have the correct permissions.)

 

Make sure that your php.ini include_path has .; at the beginning.

 

Matti

 

 

Ok ... I have the exact same problem... and yes, I restarted my server too, but it still doesn't work. I am using Apache2 with PHP 4.4.0 on a windows XP machine and trying it as a local install. Please HELP!!!!

Link to comment
Share on other sites

If you can't get around this problem, first delete all your Temporary Internet Files including all Offline Content, and set your browser to Always Look For The Latest Version Of Stored Files.

 

If it still doesn't work install the Register Globals Patch Files (link below my name).

 

Vger

Link to comment
Share on other sites

Ok ... I have the exact same problem... and yes, I restarted my server too, but it still doesn't work. I am using Apache2 with PHP 4.4.0 on a windows XP machine and trying it as a local install. Please HELP!!!!

 

I heard that you need windows xp professional edition as home wouldn't work. Don't know if that is true are not.

 

The reason I am here is because the host that I use as of Aug. 31st is going to change the value of global_variable to off for security reasons. I have a custom php.ini so it won't affect my store as I control the php.ini file. But I came here to find out how to work around this issue. Supposedly there is a way to change code to allow you to run with gv off!

 

Something to think about!

Link to comment
Share on other sites

Thanks ... it works now :)

 

New problem though. I have mysql 4.1 installed on my computer. The rest is ofcourse the same. Windows XP, PHP 4.4.0, Apache 2.

 

Agai, this is for a local installation.

 

PHP works fine with Apache. MYSQL works fine independantly. But trying to get the 3 working together, IT FAILS!

 

When I tried installing the OSCommerce, after putting in thr database details, it gave me an error as

 

" A Test Connection made to the database was NOT successful. The error message returned is

 

Client does not support authentication protocol requested by server; consider upgrading mySQL client"

 

Please click Back button below to review your database server settings.

 

If you require help with your database server settings, please consult your hosting company"

 

Please HELP!!!! :(

 

 

If you can't get around this problem, first delete all your Temporary Internet Files including all Offline Content, and set your browser to Always Look For The Latest Version Of Stored Files.

 

If it still doesn't work install the Register Globals Patch Files (link below my name).

 

Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...