Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

The sessions directory does not exist: /tmp.


Wanwan

Recommended Posts

After I have solved the permission problem, I got one more warning left.

 

The warning is print on "/catalog/index.php"

Warning: The sessions directory does not exist: /tmp. Sessions will not work until this directory is created.

 

and followed with

Warning: session_write_close() [function.session-write-close]: open(/tmp\sess_8c58db86cb7e6097b27dc5235c5b2d87, O_RDWR) failed: No such file or directory (2) in C:\XAMPP\apachefriends\xampp\htdocs\catalog\includes\functions\sessions.php on line 106

 

Warning: session_write_close() [function.session-write-close]: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in C:\XAMPP\apachefriends\xampp\htdocs\catalog\includes\functions\sessions.php on line 106

 

I don't see any tutorial listed in the documentation. Anyone can help?

 

wanwan

Wanwan -- %_%_

Link to comment
Share on other sites

/tmp is a generic setting in the admin/configuration area, you need to set the paths displayed there to your own path.

 

also, try setting store sessions in your configure.php files to mysql and not empty

Link to comment
Share on other sites

/tmp is a generic setting in the admin/configuration area, you need to set the paths displayed there to your own path.

 

also, try setting store sessions in your configure.php files to mysql and not empty

 

According to your guide, I have change the store sessions setting to mysql in configure.php

 

However, I don't know what you mean on "set the paths to my own path in admin/configuration" . What path is consider my own path? any example?

 

:huh:

Wanwan -- %_%_

Link to comment
Share on other sites

Provided you have set both of the configure.php files to store sessions in the database ('mysql') then you don't need to worry about the path to store sessions in a folder.

 

Vger

Link to comment
Share on other sites

Provided you have set both of the configure.php files to store sessions in the database ('mysql') then you don't need to worry about the path to store sessions in a folder.

 

Vger

 

You are right. After I changed the store sessions to 'mysql'. the warning message has gone!.... COOLLLL

 

 

Thank you, and Thank God! :D

Wanwan -- %_%_

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...