Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

No images are showing up...SOS


osCommercer

Recommended Posts

i was successfully installed the oscommerce but unfortunately, there texts are showing up. I've checked the images folder permission, they're all set to 777. In the admin cpanel is find but in the main pages aren't  :( Any ideas?

 

Have a look in the catalog/includes/configure.php

you may see something like the following

 

define('HTTP_SERVER', 'http://www.yourdomain.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

 

It may need to have the HTTPS_SERVER defined. for example

 

define('HTTP_SERVER', 'http://www.yourdomain.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'http://www.yourdomain.com'); // eg, https://localhost - should not be empty for productive servers

 

See how that goes

 

Trev

Link to comment
Share on other sites

Have a look in the catalog/includes/configure.php

you may see something like the following

 

define('HTTP_SERVER', 'http://www.yourdomain.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

 

It may need to have the HTTPS_SERVER  defined.  for example

 

define('HTTP_SERVER', 'http://www.yourdomain.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'http://www.yourdomain.com'); // eg, https://localhost - should not be empty for productive servers

 

See how that goes

 

Trev

 

I installed it thru the Control Panel.

here's what it shown in the config.php file

 

  define('HTTP_SERVER', 'http://domain.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://domain.com'); // eg, https://localhost - should not be empty for productive servers

 

p.s. the oscommerce was installed in the subdomain e.g http://www.domain.com/oscommerce

Link to comment
Share on other sites

I installed it thru the Control Panel.

here's what it shown in the config.php file

 

 ?define('HTTP_SERVER', 'http://domain.com'); // eg, http://localhost - should not be empty for productive servers
?define('HTTPS_SERVER', 'https://domain.com'); // eg, https://localhost - should not be empty for productive servers

 

p.s. the oscommerce was installed in the subdomain e.g http://www.domain.com/oscommerce

 

Have you got the secure certs installed on the server? If not that might be your problem. I'm no expert but I just had the same problem and it would seem that in my case the server was redirecting me through the secure side even though it wasn't installed. So I changed the

define('HTTPS_SERVER', 'https://domain.com'); // eg, https://localhost - should not be empty for productive servers

 

To define('HTTPS_SERVER', 'http://domain.com'); // eg, https://localhost - should not be empty for productive servers

 

Notice that the "s" has been dropped off the 'http://........

then it all worked perfectly.

 

Trev

Link to comment
Share on other sites

Have you got the secure certs installed on the server? If not that might be your problem. I'm no expert but I just had the same problem and it would seem that in my case the server was redirecting me through the secure side even though it wasn't installed. So I changed the 

define('HTTPS_SERVER', 'https://domain.com'); // eg, https://localhost - should not be empty for productive servers

 

To define('HTTPS_SERVER', 'http://domain.com'); // eg, https://localhost - should not be empty for productive servers

 

Notice that the "s" has been dropped off the 'http://........

then it all worked perfectly.

 

Trev

 

How do you install the SSL to server? During installation, I've selected the SSL > Yes. Is there anything else I have to do inorder for the images to be display?

 

Appreciated for your time Trev.

Link to comment
Share on other sites

you either need to purchase an ssl certificate (not a cheap one) or you need to use the host shared cert, if they provide one. for now set ssl enable to false.

Link to comment
Share on other sites

you either need to purchase an ssl certificate (not a cheap one) or you need to use the host shared cert, if they provide one.  for now set ssl enable to false.

 

shoot, i was just deleted the oscommerce then reinstalled again. Select NO to the SSL but the images still are not showing up??? :(

Link to comment
Share on other sites

Have you got the secure certs installed on the server? If not that might be your problem. I'm no expert but I just had the same problem and it would seem that in my case the server was redirecting me through the secure side even though it wasn't installed. So I changed the 

define('HTTPS_SERVER', 'https://domain.com'); // eg, https://localhost - should not be empty for productive servers

 

To define('HTTPS_SERVER', 'http://domain.com'); // eg, https://localhost - should not be empty for productive servers

 

Notice that the "s" has been dropped off the 'http://........

then it all worked perfectly.

 

Trev

 

 

I was day dreaming and didn't pay attention to https

 

they're all look so identical :D the images are now working properly

 

Really appreciated to both of you.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...