Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

PHP Fatal error:


sbudlong@optonline.net

Recommended Posts

When I get to this step

 

/catalog/install/install.php?step=2

 

I get this error message:

 

PHP Fatal error: Call to undefined function: osc_in_array() in d:\webserver\strongchoice.com\www\catalog\install\install.php on line 20

 

Is there something I can do?

 

Also, at the same step on a local testing Windows server, the PHP page loads just past the header, just below "Database Import" where it stops loading.

 

Is this some kind of permissions issue?

Link to comment
Share on other sites

  • 1 month later...

I found that I got the same error, which was tracked back to me installing the Register_global_fix contribution.

Once I removed that contribution (and changed register_global=on), the issue was resolved.

 

It appears that there is a mismatch in the version of RegisterGlobal fix available and the downloadable OSCommerce code. I have not had time to track it down. I'm running with register_global for now, but that wont work for my production system.

 

Someone surely knows more about this than I. Any suggestions?

Link to comment
Share on other sites

I got the same problem...

 

The resolution for me was error in my mysql config.

 

Make sure you have set the permissions right to the user you have specified.

 

Ex. I missed to make the 'database.*' in the GRANT command.

It should read somethin like this:

GRANT ALL PRIVILEGES ON database.* TO 'user'@'host' IDENTIFIED BY 'password';

FLUSH PRIVILEGES;

 

At least that solved it for me.

Link to comment
Share on other sites

Hi I have same problems.

 

When installing oscommerce on a brand new machine with suse 10 64 bit version, I get the same result with stopping at the database import screen, showing half of it. But when I tried exactly the same installation on an ordinary PC 32bit. It worked !!

 

Also regarding the fatal errors. I have had some of them. When checking into the code, they have allways been places were there has been a check if PHP version is greater than ## then do new_function, else do old_function.

When commenting out the new_function, it removes the error.

 

I am running PHP 4.4.0, maybe there is a problem with that version of PHP?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...