Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Flash Causing Security Pop-Up


Guest

Recommended Posts

Hello,

 

I have a flash object on the right pannel of my site, so it is on every page. I want to keep this object in flash. But the site now promts users telling them the site is secure and unsecure. This is not good. Anyone been through this?

 

<?php

 

$phponline_info_box = array();

$phponline_info_box[] = array('text' => BOX_HEADING_PHPONLINE );

new infoBoxHeading($phponline_info_box, false, false, false, $column_location);

 

 

 

 

$phponline_info_box = array();

if($phponline_status_indicator_type==1)

{

 

$phpOnlineFlashIndicator = '<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" HEIGHT="60" WIDTH="120" id="status" ALIGN="" border="0">';

$phpOnlineFlashIndicator .= '<param name="base" value="'.$phpOnline_base_url.'/"><PARAM NAME=movie VALUE="'.$phpOnline_base_url.'/status.swf"><PARAM NAME=menu VALUE=false><PARAM NAME=quality VALUE=High> <PARAM NAME=bgcolor VALUE=#ffffff><param name="salign" value="TL"><param name="scale" value="NoBorder">';

$phpOnlineFlashIndicator .= '<EMBED base="'.$phpOnline_base_url.'/" src="'.$phpOnline_base_url.'/status.swf" menu=false quality=High bgcolor=#ffffff NAME="status" ALIGN="" TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer" salign="TL" width="120" height="60" scale="NoBorder"></EMBED></OBJECT>';

 

$phponline_info_box[] = array('align' => 'center',

'text' => $phpOnlineFlashIndicator

);

 

}

if($phponline_status_indicator_type==2)

{

$phponline_info_box[] = array('align' => 'center',

'text' => '<a href="java script:phpOnlinePopupWindow()">' . tep_image($phpOnline_base_url.'/statusimage.php' , BOX_INFORMATION_PHPONLINE ). '</a><br>'

);

}

 

 

new infoBox($phponline_info_box);

 

?>

Link to comment
Share on other sites

Hey Pure Vida,

 

Try to change the http definitions in the flash stanza to https

 

Example: https://www.macromedia.com/go/getflashplayer

 

 

cheers,

Gregg

Link to comment
Share on other sites

Thanks for responding!

 

Could you give me some more detail on this, perhaps a 1.2.3 break down. I am sure this will be helpful to others as well on how to solve this.

 

Cheers!

 

 

Hey Pure Vida,

 

Try to change the http definitions in the flash stanza to https

 

Example: https://www.macromedia.com/go/getflashplayer

cheers,

Gregg

Link to comment
Share on other sites

Thanks for responding!

 

Could you give me some more detail on this, perhaps a 1.2.3 break down. I am sure this will be helpful to others as well on how to solve this.

 

Cheers!

 

sure..

When you cut and past the object definition provided from flash there are urls included that link back to flash.

 

just change every instance of http in the object definition to https.

 

This should stop the error message from popping up.

 

Cheers,

Gregg

Link to comment
Share on other sites

sure..

When you cut and past the object definition provided from flash there are urls included that link back to flash.

 

just change every instance of http in the object definition to https.

 

This should stop the error message from popping up.

 

Cheers,

Gregg

 

Great! That worked. What an easy fix.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...