Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Problems with installation!


Recommended Posts



I'm installing OS commerce on a brand new operating system with windows XP pro. I have done the following


1. Installed IIS V.5

2. Installed My SQL server service Manager v8.

3. Installed PHP

4. Downloaded the Os commerce file to a temp dir.

- Copied the 'Catalog' folder to my C:\Inetpub\wwwroot\htdoc\ directory.

- Note: I had to create the htdoc folder because I did not have one.

5. Open my IE to: http://'computername"/htdocs/install/index.php

-I can see the os Commerce install page but, its not identical to the one on the Help Web Based Installation Procedure. It douse not show the Version type nor the language drop down menu.

6. Click on Install --> This page shows OK. I check both of the box's Click on Continue

7. The Database Import page DOUSE NOT show me the Database Type or Prefix. I fill out everything else and click on Continue. The next page hangs. (nothing happens) I only see the New Installation text and the OScommerce logo.

8. At this point I'm stuck.


Can anyone help me out with any Suggestions

It looks like its not seeing the SQL server Manager.

Link to comment
Share on other sites

Hi Erick,


4. From what I know, htdoc is the root web directory for Linux/UNIX. For IIS, it's wwwroot. Thus, it's not necessary for you to create the htdoc directory in your case. You can move the contents of catalog folder to wwwroot if you wish.


5. If it's installed on a remote server, try accessing at http://yourdomain.com. It will automatically redirect you to the install page if it's the first time. If it's installed on your local server, try accessing at http://localhost.


See if this helps... :blush:

Link to comment
Share on other sites


I'm runing everything local

I have moved the CATALOG folder the root dir: http://localhost/catalog/

It takes me to the install process but I'm still runing to the same problems.



I did find something out.

I'm runing SQL server 2000 desktop Engine (MSDE 2000) release A

I'm not runing the actual SQL server enterprice.

---Can anyone tell me if this is the problem?

---any of you guys using the desktop engine only and it works?




Link to comment
Share on other sites

I had the same issue today. It turned out that the php.ini did not have the mysql enabled. you will also need to copy the php_mysql.php and libmysql.dll to the windows\system32 dir. also in the php.ini do a search for ./ and replace it with C:\windows\system32, it will be different if you have windows installed in a different dir. Good luck it should start working for you, oh and dont forget to restart the web services to load the modded php.ini. P.S. php.ini is in c:\windows.

Link to comment
Share on other sites

Thank you so much. You led me to the answer to my problem as well. mysql was disabled in php with the default install. all I had to do was remove the semicolon lol I have been working on this for 5 hours now. amazing how a simicolon can cause so much headache lol


I am posting the fix for mine under my thread I am giving you credit though. I hope you dont mind.


Thank you again

Link to comment
Share on other sites

Must be me!


OK, I have followed the procedures you suggested.


1. PHP.ini did have the mysql enabled

2. Did not find the php_mysql.php file, I did find php_mysql.dll file.( not sure if that is the actually file you ware referring too)

-I did copy the php_mysql.ll to the c:\windows\system32 dir.

3. Copied libmysql.dll to the windows\system32 dir

4. I edit the php.ini, change the ./ and replace it with C:\windows\system32

5. Restarted my computer

6. Open IE to http://localhost/catalog/

7. Took me to the install site but, SAME PROBLEM, I do not see the Database Type or Prefix.


Any other suggestion?

I did un-installed and re-installed the SQL desktop Engine and nothing.

Do I need to make any other changes to PHP.ini?

What about any aditional settings on IIS?

Link to comment
Share on other sites

Do yourself a favour - dump Windows IIS. In an online environment you'd be better off on an Apache server anyway - so why not save yourself all of this grief trying to set up IIS and install Apache instead?


If you want to do that then uninstall IIS etc and download and install the XAMPP all-in-one package - one click and it installs and works. You'll find it here:




Link to comment
Share on other sites


I gave up with IIS. I uninstall IIS etc and download and install the XAMPP all-in-one package.


1. I have copied over the catalog folder to the C:\apachefriends\xampp\htdocs dir

2. I have change the permission to the dir

3. ran the install:

4. On the page: Database Import : Please enter the database server information

- I run into this PROBLEM, When I put a Database Name it keeps telling me "Access denied for user ''@'%' to database 'oscommerce'"

(I was not even getting this far last time)


- 1. How do I know what the database name is if I never created one??

- 2. Can some one tell me where is located? or how to created one?

- 3. I have looked at the configure.php file and shows: define('DB_DATABASE', 'osCommerce');


Vger, The installation of apache server is much better the IIS and all the 3rd party components. I would highly recommended to everyone else.

Link to comment
Share on other sites

The easiest way for you to create your databse and users etc without knowing SQL is to use a third party program like Mysql Administrator. A better way is to use some more full featured like phpmyadmin but for your purpouses mysql administrator should do what you need. You can download it here

Mysql Administrator


Download and install this.


1. Once installed create a connection to your mysql server using the user name and password you set up when you install mysql.


2. Once connected click catalog at the left at the bottom left I believe you will see a database called mysql. Right click on it and then click create new schema. Enter the name you want to use for the database in the box that pops up. that creates your database. Now you need to creat a user


3. at the top left click on User Administration and at the bottom middle you will have a button that says New User, Click it


4. Fill in the user name and password you would like to use for your new database then click the Schema Privelages tab at the top middle.


5. Select your new database from the list then click the double arrow pointing to the left in the middle of the window. this grants the user full permissions to that database.


6. click the apply changes button at the bottom


7. Run the oscommerce install and feed it the database name, user name, and password you just configured and this should import the tables to the new database.


All this of course assumes you have already installed mysql on this system.


Hope this helps point you in the right direction

Link to comment
Share on other sites



FIRST and for most I want to:


THANK each and one you guys for the GREAT help but I quit!


Seriously, I want to THANK YOU ALL for the great service.


IT ALL WORKS now, The SQL Admin made it simple. I was able to install Oscommerce and test the site on my local PC.


I'm a webpage designer and not much of a developer. So this sql stuff and not my thing. If you guys have any othe sugestion to make life a little more simple it will be great.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...