Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Easy Populate & Products Attributes


Recommended Posts

Ok, now I'm completely stupid when it comes to scripting and all of that other good stuff... To put a long story short, I have to keep on my toes because all of my product inventory is based on my suppliers website. Recently he changed things in almost every single category, and It is going to take me forever to do everything one by one. I came across this little tool called easypopulate and thought that it was going to save my life. Well, I finally got it all installed and working (after fiddling with it becuase I had to go and change my default directory setup)... but now I have no clue what to do. I downloaded the .txt file to import into Excel, but all of the prices and stuff are in columns they shouldn't be in and so forth. I really only need a couple of headings for my site. Well, I tried to put things in their "right" columns and got the following error:


Warning: move_uploaded_file(/home/jeliteba/public_html/public_html/tmp/EP2005Apr23-2109.txt): failed to open stream: No such file or directory in /home/jeliteba/public_html/admin/easypopulate_functions.php on line 32


Warning: move_uploaded_file(): Unable to move '/tmp/phpUMYhGg' to '/home/jeliteba/public_html/public_html/tmp/EP2005Apr23-2109.txt' in /home/jeliteba/public_html/admin/easypopulate_functions.php on line 32


File uploaded.

Temporary filename: /tmp/phpUMYhGg

User filename: EP2005Apr23-2109.txt

Size: 26890


Warning: file(/home/jeliteba/public_html/public_html/tmpEP2005Apr23-2109.txt): failed to open stream: No such file or directory in /home/jeliteba/public_html/admin/easypopulate.php on line 665


Warning: Invalid argument supplied for foreach() in /home/jeliteba/public_html/admin/easypopulate.php on line 688


So, yeah. I'm stuck. If there is anyone out there who could help me customize this for my store with the limited headings that I would need as well as help me get it working, I would appreciate it. Thanks!

Link to comment
Share on other sites

read thru the documentation for where to place you temp directory and the file permissions.

then look at your path: two public_html's, so your path is afu . .



Link to comment
Share on other sites

Good Afternoon.


I have taken a copy of my hosted website and downloaded the whole thing for use on my local machine. I was able to correct the configure.php in catalog and admin to connect to my local database and to set the server information to localhost.


Everything works fine so far except this one problem.


I created an EP file that I wanted to import into my local machines database. I choose the EP file then click insert into database and it comes back with this information.


File uploaded.

Temporary filename: /var/tmp/phpcckWxy

User filename: EP2005.txt

Size: 40825


It does not show me the listed of files being uploaded as it did when I was remote it just comes back with the above information with no data added to the database.


Could someone explain to me or help me correct the problem.



Link to comment
Share on other sites

if using your windows system, you need to set the proper temp file path, else it doesnt work





I am not on a Windows System I am currently using OS X.


I wonder this.


My absolute path is this.




or I have a temp folder in my my Documents directory as I do not use the catalog folder but I do have a /temp folder in there.


My other temp directory is here.




I have tried the following two paths and niether changes the problem that I am having.


I have tried




and /Library/WEbServer/Documents/temp/


And I still have the same problem.


Can you give me any further information about how to set the path locally.


Thank you.



Link to comment
Share on other sites

Hi all, im using the easy populate option to upload products, now in my spreadsheet i have a column for the product ID or model number, now what do i need to call thaht column for the id numbers or model numbers to be placed in the "Products Model:" form field in my loaded sites admin.


I mean in my spreadsheet with all my products i have a column thaht has teh product code or id number. Now the column is called "Product Code" now when i login into my oscommerce sites admin there is teh form field if i go to add a product called "Product Model:" now how can i make sure my column in my spreadsheet with product id goes in there please.


Thanks people

Edited by Mark-UK
Link to comment
Share on other sites

the product id field is handled automatically by the system and ep, if you have that column in your file, then you have not downloaded ep from the contribution sectin

Link to comment
Share on other sites

I need to know what field that maps to in the database, and how you could import it using EasyPopulate


He is talking about the *Product model:* form field in my oscommerce admin, when i fill in the details for a new product there is the field isnt there for the product model, in easy populate how do we make sure the product model details get put in that section please.


What should the column be named as on the spreadsheet to be uploaded, i have a columns with all my product details in and 1 clumn is for the product model id number and obviously we want htis to be in teh form field product model in my site on the page for thaht product in admin.

Link to comment
Share on other sites

ok sorted that now thanks folks. What i want to know now is in my product spreadsheet some of my products have options like colours and in my spreadsheet this is shown as each colour option is a seperate product with the same product code except the last digit, now when i upload my spreadsheet is it going to add these prodicts as seperate products or somehow make it 1 product with colour options.


So for instance row 10-15 of my spreadsheet is the same t shirt in 5 different colours, everthing is the same on each line from 10-15 except the final digit in the product code, BUT usually in my spreadsheet when a product doesnt have options its just 1 set of numbers in the product code column BUT when theres options like colours theres an extra set of digits and its the last digit thats different.




3455 (product with no options)


then any product with options in the spreadsheet has product code numbers like below.


2333 4555

2333 4556

2333 4557

2333 4558


So when i upload my spreadsheet will these products with options thaht appear on seperate lines be een and added as individual products so i have 5 products all the same t shirt in different colours or will my easy populate make it 1 product with colour options.


Phew and thanks folks.

Link to comment
Share on other sites



I recently made a copy of my shop and found a new host.

Now EP (2.72) isn't working properly anymore.


When I upload a file I get the following output:


File uploaded. 
Termporary filename: /tmp/phpZLigUS
User filename: easy populate.csv
Size: 171889
| 200 | ergo-contr | Ergo Contr | Cane Creek | | 49.94 | 0 | | 2004-02-11 | 0 | Cane Creek | Handvatten | | | Taxable Go | Active Updated
| 201 "tm- | 202 "ket | 203 "spa | 204 "oph | 205 "gig | 206 "spo | 207 "unl | 208 "twi | 209 "spo | 210 "2-d | 211 "3-d | 212 "4-d | 216 "bik | 217 "str | 222 "wat | 223 "wat | 224 "wat | 227 "ban | 228 "nas | 233 "zij | 234 "pol | 237 "pha | 239 "pet | 240 "min | 241 "com | 242 "lig | 243 "pea | 244 "tua | 245 "ada | 246 "shi | 247 "fib | 248 "fib | 249 "fib | 250 "cat | 251 "cat | 253 "air | 254 "mt2 | 255 "rol | 257 "lif | 258 "lif | 259 "toe | 261 "atb | 262 "vli | 263 "pc4 | 264 "pc4 | 265 "pow | 266 "cnh | 267 "cnh | 268 "ser | 269 "pd- | 272 "zef | 273 "ab1 | 274 "nbt | 275 "spo | 276 "dic | 277 "tra | 278 "tra | 279 "tra | 280 "tra | 281 "lic | 282 "eld | 283 "lep | 284 "san | 285 "san | 286 "san | 287 "san | 288 "san | 289 "ene | 290 "pro | 291 "ene | 294 "No- | 295 "No- | 296 "No- | 297 "No- | 298 "csh | 299 "cs_ | 300 "ali | 301 "deo | 302 "rdm | 303 "No- | 304 "fdm | 305 "fd_ | 306 "roa | 307 "roa | 308 "mac | 309 "mac | 311 "mac | 312 "fie |


While the same file works on my old shop, and also on my local system.


Is it the MySQL version or has my new host has a different setting?


How can I solve this?





Link to comment
Share on other sites

I do have a temp directory, but there is no path in admin/includes/configure.php

only in the catalog's includes/configure.php.

The csv file does end up in this temp directory.


Even if I put the file first in the temp dir, and then I "import from /temp/ dir. The results are the same.


Or should I add a temp/dir path in the admin/includes/configure.php?



Link to comment
Share on other sites

in the top portion of your easypopulate.php file, there is a setting you setup for the proper path to your temp directory, it is based upon document root and the catalog directory location

Link to comment
Share on other sites

Easy Populate 2.62-MS2 - Default Language : Nederlands(4)


Filename: EP2005apr28-1111.txt



v_products_model v_products_image v_products_name_4 v_products_description_4 v_products_url_4 v_products_name_17 v_products_description_17 v_products_url_17 v_products_name_18 v_products_description_18 v_products_url_18 v_products_price v_products_weight v_date_avail v_date_added v_products_quantity v_manufacturers_name v_categories_name_1 v_categories_name_2 v_categories_name_3 v_tax_class_title v_status EOREOR


All v_products_model numbers are present!

All EOREOR are present!


2/ [first product]

n/ [other products]

3/ [last product]


4/ | | | | | | | | | | | | | | | | | | | | | |


5/ No products_model field in record. This line was not imported


The problem:

Either the first row or the last row is not imported.

Sometimes (cannot reproduce) it seems that all products are imported?


Please advise.

"If you're working on something new, then you are necessarily an amateur."

Link to comment
Share on other sites

Call me stupid but my easypopulate.php is blank (no errors, nothing) :(


I've read through this post (and others), I've read the instructions, I've got a correctly chmod'ed temp folder and the document root is correct too.



osCommerce 2.2 Milestone 2

easypopulate.php,v 2.75 2005/04/05 AL

on *nix


OSC works fine and I've got my admin/ protected with .htaccess file (maybe that's what causes it?).


My temp folder is set as /temp/ (as in webroot -> /new/shop/temp/)

My shop is in a /new/shop/ (http://www.ampaintball.co.uk/new/shop/)


Any pointers are much welcomed :D





Edited by axelsegebrecht
Link to comment
Share on other sites



I had both of these installed before & the best I could do was to only use EP to ADD new products, but had to do the attributes separately through Admin. I could never use my same Excel file to upload a new one (I had hoped to keep a separate Excel file for backup & for making global changes) or it would wipe out all installed attribs for current products. Kind of a pain there.


I think I have seen a version of EP that will handle the attributes, but I haven't tried it, and don't remember if I saw it in Contributions or just discussed on the forums.




Link to comment
Share on other sites

See the attributes in a really big deal for me, because the site i'm working on is for selling soccer shirts, and i need an "add name" and "add number" text box for every shirt (100s of different shirts). It will take me forever to add all the attributes manually :'(

Link to comment
Share on other sites

what are you showing in your admin/includes/configure.php as document root?

also, go into admin/tools/file manager and then click on the folders getting down to the admin/includes, then at the top will show a path, what is that?

Link to comment
Share on other sites

I'm a newbie in OSC and i have a major error with easypopulate.

I installed all like it is sayd in the readme file and i created a temp dir with cmod 777.

When i try to start easypopulate a error apears


Parse error: parse error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home/roger/public_html/faisoesloja/admin/easypopulate.php on line 231


What can i do?



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...