Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Easy Populate & Products Attributes


Recommended Posts

what is your path for your temp?  it still could be there if you can not upload.

did you modify anything in the ep file out of the ordinary?


thanks for the quick reply.


I'm currently working in http://rsno.cathcartbaptist.org.uk/discography/


and my temp file is in /discography/temp


So in the ep file I have:


// **** Temp directory ****
// if you changed your directory structure from stock and do not have /catalog/temp/, then you'll need to change this accordingly.
$tempdir = "./temp/";
//$tempdir2 = "./temp/";


Although I have tried a number of variations of this (like /discography/temp etc) and none of them are having any different results. I found that only the above way works for downloading to the temp file.


Excuse my thickness!

Link to comment
Share on other sites

you dont need to do that, as easypopulate doesnt have an effect on the others.  where is the store located?  under catalog or under the root?


We were going to move it anyway but I would still like to get to the bottom of the problem. The store is in public_html/rsno/discography

where 'discography' replaces the default 'catalog' folder and 'rsno' is the subdomain ie. http://rsno.domain.com/discography

Link to comment
Share on other sites

Hello Easy Populate Experts!


I'm a beginner here.... I have my txt file all filled in and ready to upload, but I keep getting this error:


Warning: move_uploaded_file(/home/httpd/vhosts/talktomeonline.com/httpdocstemp/EP2004Nov18-0909.txt) [function.move-uploaded-file]: failed to create stream: No such file or directory in /home/httpd/vhosts/talktomeonline.com/httpdocs/osCommerce/admin/easypopulate_functions.php on line 32


Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpI5JEjz' to '/home/httpd/vhosts/talktomeonline.com/httpdocstemp/EP2004Nov18-0909.txt' in /home/httpd/vhosts/talktomeonline.com/httpdocs/osCommerce/admin/easypopulate_functions.php on line 32


File uploaded.

Temporary filename: /tmp/phpI5JEjz

User filename: EP2004Nov18-0909.txt

Size: 559620


Warning: file(/home/httpd/vhosts/talktomeonline.com/httpdocstemp/EP2004Nov18-0909.txt) [function.file]: failed to create stream: No such file or directory in /home/httpd/vhosts/talktomeonline.com/httpdocs/osCommerce/admin/easypopulate.php on line 657


Warning: Invalid argument supplied for foreach() in /home/httpd/vhosts/talktomeonline.com/httpdocs/osCommerce/admin/easypopulate.php on line 680


This is driving me frieking batty. I keep reading that the file permissions on catalog/temp should be CHMOD777, I've done this. In fact, I wasn't sure where exactly to create catalog/temp, so I have created them in every place I can think of.... lol Still, no dice.


Please help me. I have to get my products uploaded. They are simple, just a price, a pic and a short description of each. Nothing fancy. I just don't want to have to pay someone to type them all in for me.










I'd been working on getting easypopulate to handle product attribs, and managed to achieve something functional. I haven't tested the code extensively yet, but it should theoretically be capable of handling any number of product options, option values, and languages.


This is still beta code, and I haven't put it up as a contribution yet. If anyone is interested in giving this a try (at their own risk!), you can download my easypopulate.php file, and a sample tab-limited file (from an 'out-of-the-box' osc product list), here.


Please try this on a test osc setup, before you even think about using it in your "live" store. And in any case, BACKUP your database.


This code was developed and tested with EP version '2.62-MS2' on oscommerce 2.2-MS2.


Here's an overview of the system. Hope its not confusing as it looks, and  makes some sense :). 




1. v_attribute_options_id_1

2. v_attribute_options_id_2


1. v_attribute_options_id_x

 x = a count, beginning from 1, and incrementing by 1

This column contains the options ID (each option ID must be unique).
2. v_attribute_options_name_x_y

 x = count (same as above)
 y = count and language id . This means, language id must correspond to the count, begin on 1, and increment by 1. 

For example, 

correct language id structures include, 

 English (ID = 1), German (ID = 2) and Spanish (ID = 3)
 English (ID = 1) and French (ID = 2)

and the system most likely won't work with the following language id structures, 

 English (ID = 2) and German (ID = 3)
 French (ID = 2)
So basically, if you're using 3 languages (say, English, German and French) make sure their language ids begin with 1, and increment by 1, without jumping values. 

This column contains the option name (in each language).

3. v_attribute_values_id_x_y

 x = corresponding option count
 y = option values count, beginning from 1, and incrementing by 1

This column contains the option value ID (each option value ID must be unique).
4. v_attribute_values_price_x_y

 x = corresponding option count
 y = option values count

This column contains the "signed" price. If non-empty, attribute value is added to the product. 
5. v_attribute_values_name_x_y_z

 x = corresponding option count
 y = corresponding option values count
 z = count and language id . This means, language id must correspond to the count, begin on 1, and increment by 1 (please see description for v_attribute_options_name_x_y).




Basically, if the field "v_attribute_values_price_x_y" is not empty for a product row, the corresponding attribute is added to that product. Example non-empty values include,


0 (zero) = just the attribute is added (there's no special price)

11.50 = attribute is added, with price value 11.50, and price prefix '+'

-9.30 = attribute is added, with price value  9.30, and price prefix '-'


You'll also be able to add product options/option values, modify option/option value names.


Link to comment
Share on other sites

with this:


Warning: move_uploaded_file(/home/httpd/vhosts/talktomeonline.com/httpdocstemp/EP2004Nov18-0909.txt)


shows me you have a document root problem in your configure.php file in the admin/includes/configure.ph:




thus you can either find where you are missing the / or it could be your temp listing in easypopulate.php needs a /

Link to comment
Share on other sites

I've gone through as many posts as possible and I did not come across this problem. I have installed the November 11 easypopulate. I have followed the directions and installed everything correctly. My problem is, I'm not getting any error messages, but when I try to download the screen just refreshes and that's it. I've tried uploading and it does the same thing. Temp directories have been created, they have the correct permissions. Not really for sure what steps I need to go next.




Link to comment
Share on other sites

the nov 11 is not the complete package, someone decided to add some fields to it, and uploaded it. get rid of that one, then download the 12 aug version and install that one.

Link to comment
Share on other sites

the temp path should be /discography/temp/


That would make sense but when I have it as that and try to download to temp I get the following error:

Warning: fopen(/home/cathcart/public_html/rsno/discography//discography/temp/EP2004Nov19-1111.txt): failed to open stream: No such file or directory in /home/cathcart/public_html/rsno/discography/admin/easypopulate.php on line 603

Warning: fwrite(): supplied argument is not a valid stream resource in /home/cathcart/public_html/rsno/discography/admin/easypopulate.php on line 604

Warning: fclose(): supplied argument is not a valid stream resource in /home/cathcart/public_html/rsno/discography/admin/easypopulate.php on line 605
You can get your file in the Tools/Files under /discography/temp/EPEP2004Nov19-1111.txt


Whereas, downloading to temp seems to work successfully when I have it as just /temp/

I still get the immediate 'Resource cannot be displayed' 406 error when i press any of the upload to db button, nomatter what I have as my temp path. I get the feeling its not an issue with the temp path (well that may still cause a problem but further down the line).

Edited by starkie
Link to comment
Share on other sites

you have problems with your configure.php file,most likely the document root and until that is fixed it wont work right. post the admin/includes/configure.php without the database info.

Link to comment
Share on other sites

I have two online stores.






They are boths on the same server, and use a shared SSL supplied by my hosting services.


The first store is a general store, and the second one is an ink specialised store.


To make the second store, I simply duplicated the first one with its database, and remove what was non-ink products.


I took care of changing ezclikshop for encredirect in the configuration files.


In fact the store works.


But I can't easypopulate encredirect.net, as I used to do, and I am still able to do with the same file on ezclikshop.net.


Can someone help me with this one?


Link to comment
Share on other sites

did you set the temp directory location in different spots in the easypopulate files, they need to be different


the temp files are defined as:


$tempdir = "temp/";

$tempdir2 = "temp/";


My store admin config file is:


define('HTTP_SERVER', 'https://www.securewebexchange.com/encredirect.net'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'https://www.securewebexchange.com/encredirect.net');

define('HTTPS_CATALOG_SERVER', 'https://www.securewebexchange.com/encredirect.net');

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/services/webpages/e/z/encredirect.net/secure/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/********/'); // absolute path required

define('DIR_FS_ADMIN', '/services/webpages/e/z/encredirect.net/secure/********/'); // absolute pate required

define('DIR_WS_CATALOG', ''); // absolute path required

define('DIR_FS_CATALOG', ''); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');


As I said, the store works



Edited by DanielG
Link to comment
Share on other sites

Daniel, are you sure everything is duplicated exactly? You haven't added any other contributions? I have had nightmares trying to install easypopulate because I have More Pics 6.0 installed. It simply doesn't work and no one seems to be able to help me either.


If anyone does have EP working with Mo_Pics6.0, please private message me or send me an e-mail.

Link to comment
Share on other sites

daniel, what is your document root path?

go to tools/server info and search for document_root then post that here.

it has to be a setting, it appears you are running ssl 100% of the time on the site from your configure.php file and it is a dubdomain of another domain.

Link to comment
Share on other sites

I am using EasyPopulate 2.60 and I just have one question.. I am sure the answer is in here some where but I bet you can answer for me in a way I can understand :P When ever I upload my inventory the price goes in to net and it should go into gross... how do i change this.. or is there a setting on my store where when every I upload it just shows the price i have on my EP inventory... an example i upload a product for 299.99 and it shows on the store for 280.xx Any help would be much appreciated... Thanks! B)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...