Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Cookies, Shared SSL, and Configure.php Problems


designext

Recommended Posts

I am having a problem with my site at http://www.bayoupizzazz.com/catalog/

 

When you add an item to the shopping cart and then click checkout, the shopping cart disappears. I believe this may have something to do with the way the shared ssl is setup at our host. This problem just started occuring when we set it up to run on the SSL.

 

Here is the current config file...

define('HTTP_SERVER', 'http://www.bayoupizzazz.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://bayou004.secure.omnis.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'bayoupizzazz.com');

define('HTTPS_COOKIE_DOMAIN', 'bayou004.secure.omnis.com');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

It seems the problem is with cookies or sessions not being passed from the standard URL to the secure one. Does anyone have any ideas what might be happening?

 

Also, just a little more info... our host requires secure files to be placed in an SSL directory (outside of the normal WWW directory). As a result, we have to maintain a duplicate copy of what is in the www/catalog folder at ssl/catalog.

 

Any help would be appricaited. Thanks!

Link to comment
Share on other sites

from this:

define('HTTP_COOKIE_DOMAIN', 'bayoupizzazz.com');

to this:

define('HTTP_COOKIE_DOMAIN', 'www.bayoupizzazz.com');

it may help, hard to say.

what are your session settings in admin/configuration

Link to comment
Share on other sites

I noticed that if you try to go to:

 

https://bayou004.secure.omnis.com you'll get a 403 error. But if you go to

 

https://bayou004.secure.omnis.com/catalog/ you'll reach the site.

Strange server setup.

 

I'd try:

 

define('HTTP_SERVER', 'http://www.bayoupizzazz.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://bayou004.secure.omnis.com/catalog'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.bayoupizzazz.com');

define('HTTPS_COOKIE_DOMAIN', 'bayou004.secure.omnis.com/catalog');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/');

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...