Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Htaccess - Public Area asking for PW


Joe689

Recommended Posts

I first want to thank everyone who works on this project. This project like all the other freesource projects has had such a great effect on the www.

 

My problem is:

 

When I first transferred the main catalog directory, it was unable to transfer the htaccess files because of some server problem. Not a big deal, I manually through my webhosting(yahoo) created htaccess in the admin directory. The only place I have htaccess is in the admin directory. The problem is when I go to the main shopping catalog that should be public, a password prompt asks for the username and password. This is needed for about 4 images on the page. The password is needed for the quick find button image and the 4 lanugage images. These are practically in all the pages of the shopping cart so it is causing a great incoveniance. You can cancel the password prompt but that the images are not found. I tried locating the orgin of these files and I could only find the orgin of the language images and they lie in a directory where there is no htaccess. I was wondering if anyone else has had this problem. What can I change to fix or work around the problem.

 

Thanks

JOE

Link to comment
Share on other sites

Sounds like you password protected the folder that those images are sitting in-or one of its parent folders. Find the folder, and edit your htaccess.

 

Probably...

Quidquid latine dictum sit, profundum viditur.

Link to comment
Share on other sites

Sounds like you password protected the folder that those images are sitting in-or one of its parent folders.  Find the folder, and edit your htaccess.

 

Probably...

 

I am unable to find the location of quick find button but I did find the location of the language icons are they are in an includes directory. The directory nor its parent has htaccess.

 

thanks

joe

Link to comment
Share on other sites

I am unable to find the location of quick find button but I did find the location of the language icons are they are in an includes directory.  The directory nor its parent has htaccess.

 

thanks

joe

Hmmm... Not sure then.

I think the quick find button is in catalog includes/languages/english/images/buttons.

 

Is this a new install?

 

What changes have you made lately? Seems to be language related.

Quidquid latine dictum sit, profundum viditur.

Link to comment
Share on other sites

I am unable to find the location of quick find button but I did find the location of the language icons are they are in an includes directory.  The directory nor its parent has htaccess.

 

thanks

joe

I haven't made any changes.

 

You can take a look at http://imagexchange.biz/catalog/

 

I have changed nothing in the code, if I take the htacess out of the admin folder , it still asks for password. Where could this be coming from? maybe its serverside? There is no htaccess in the directories with the buttons.

 

thanks

joe

Link to comment
Share on other sites

I haven't made any changes.

 

You can take a look at http://imagexchange.biz/catalog/

 

I have changed nothing in the code, if I take the htacess out of the admin folder , it still asks for password.  Where could this be coming from? maybe its serverside?  There is no htaccess in the directories with the buttons.

 

thanks

joe

 

 

I FIXED THE PROBLEM. I should of figured it was yahoo serverside garbage. Yahoo webhosting is one of the worst. They do everything their own way and don't use standard conventional ways of managing a website. Thanks for your help though. Keep up the hard work!

Thanks

JOE

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...