Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

price


scottvc

Recommended Posts

Hi Peoples

 

I have had a bit of a troll through the knowledge base and forums but have not been able to see a solution to my problem.

 

when viewing items in the shop the price displayed is "0", yet when viewed as a preview from the admin section the price is there.

 

Anyone had this problem before? Yes a net and gross price is used, a net price is entered and then the tax is calculated. Have varied this as a non-taxable item and taxable, with decimal points and as a "whole' figure, still the same result.

 

Help please????? :'(

Link to comment
Share on other sites

Have you have changed the ndefault currency?

 

If so, look in catalog/includes/languages/english.php (or whatever language you are using) and find the lines

 

// if USE_DEFAULT_LANGUAGE_CURRENCY is true, use the following currency, instead of the applications default currency (used when changing language)

define('LANGUAGE_CURRENCY', 'USD');

 

Change the 'USD' to the 3 letter code for your currency ('GBP' if you're in the UK for example)

Link to comment
Share on other sites

Hi Peoples

 

I have had a bit of a troll through the knowledge base and forums but have not been able to see a solution to my problem.

 

when viewing items in the shop the price displayed is "0", yet when viewed as a preview from the admin section the price is there.

 

Anyone had this problem before?  Yes a net and gross price is used, a net price is entered and then the tax is calculated. Have varied this as a non-taxable item and taxable, with decimal points and as a "whole' figure, still the same result.

 

Help please?????  :'(

 

 

I'm having this problem too. Sort-of. But it's with a digital product in

the Music catagory. I have another product in the book catagory and

it displays the price as it should when it's added to the cart. But not the

Music.

 

The price displays in the admin area, and in the store,, but it doesn't

get added up during checkout. I FTP'd the .mp3 into the "download"

file, and set it up in the "attributes" area too. So everything in admin,

and the catalog is displaying as it should. It just doesn't get added

up in the check out.

 

Ron <_<

Link to comment
Share on other sites

I think I resolved this problem.

 

When I set up this product I set the attributes before adding

it to a catagory.

 

After experiencing problems I deleted the product and started

over, this time adding the product to a catagory before setting

attributes.

 

After that the price added up correctly on the cart area.

 

Maybe someone else can explain why that worked,, I have

no idea.

 

Ron B)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...