Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Strange things are happening to my shop...........


---Kate---

Recommended Posts

My shop has started acting strangely!!!!! :blink:

 

My shop has problems when adding items to the cart from a catagory page, if I use the buy now buttons on the catagory page it does not add the product to the cart, but instead emptys out anything that is already in the cart. I can only add the products from the individual product pages. (This used to work a few days ago, but has changed on me - I have added some contributions since then so not sure if any of them are affecting this).

 

I also have a problem with the dangling carrot contribution I have added. This used to work properly but since adding some product attributions to pick from for the free gift, I can now add the free gifts to the cart without having to have spent the ?20 limit required to get the gift. I can also add as many free gifts as I want without buying anything!

 

Hope someone can help! :(

Link to comment
Share on other sites

(This used to work a few days ago, but has changed on me - I have added some contributions since then so not sure if any of them are affecting this).

 

 

The added contributions are the likely place to start. Restore to the version of a couple of days ago that worked--then add your new contributions again one-by-one, testing after installing each one. Shouldn't be hard to pinpoint where things went wrong.

"Buy the ticket, take the ride..." -HST

Link to comment
Share on other sites

Unfortunately I overwrote my working backup with a recent backup that doesn't work properly either (I thought it did when I did the backup). I know, that was really dumb! :( But can't change that now. The only working backup I have now is from before I starting customising my shop. :(

 

My site is here : My Shop

 

Hope someone can help in some way!

Link to comment
Share on other sites

Ok - panic over!

 

I have got my catagories and products back, and adding to the shop.

 

My problem was with the ultimate seo urls contributions. I think I added some code in the wrong place in the includes/functions/html_output.php, so I have taken it out and my shop works. But now I need to find out where to put the code in. So I am off the search the forums for some help on this contribution.

 

Thankyou to anyone who has taken time to look at my site/problems.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...