Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

MP3 Preview & download folder


Don Gawgon

Recommended Posts

Hi,

 

I have a custom store that has a department/category of MP3 instrumentals. I am in the process of converting the store to osCommerce.

 

I have a Flash player that reads an mp3 file and plays that file simulaneously with a voiceover loop. This is to prevent people from stealing the sample, looping it, and recreating the instrumental. After the user buys the instrumental, they will be able to download the voiceover-less instrumental from the download folder using (hopefully) the standard osCommerce download module.

 

I have the instrumentals in the download folder and modified the .htaccess file that comes with the default osCommerce to allow the player access to this folder as follows:

 

New:

 

Options -Indexes
Order Allow,Deny
Allow from .mydomain.com

 

Original:

 

AuthType Basic
AuthName "No access"
AuthUserFile .htnopasswd
AuthGroupFile /dev/null
Require valid-user

 

With the new .htaccess I no longer get the "no access" logon box but the player can't read the file. See it here: http://www.life-or-death.com/catalog/produ...?products_id=29 by clicking the play button in the product decription. The "life or death" voiceover plays but the instrumental doesn't. I test the player in my local environment and it works.

 

What should I have in my download/.htaccess file to get this to work?

 

Thanks In Advance

Link to comment
Share on other sites

For now, I have it working with the following .htaccess:

 

Options All -Indexes

 

Is this sufficient security-wize? I may put back the directive to only allow access from the site's domain. Will this .htaccess screw up the download module or anything else? :blush:

Link to comment
Share on other sites

I seem to be talking to myself here! :wacko: Anyway, I ended up going with osPlayer lite and will likely modify the player to automatically play a voiceover.

 

By the way, in the osPlayer lite contrib, the Advanced section of the english instructions has not been updated with the missing </object> tag fix.

Link to comment
Share on other sites

  • 2 months later...

im having the same problem, and also the auto play funciton doesnt seem to work..

 

guh!!! did you figure out anything new?

 

more doc is needed for osplayer indeed

 

I seem to be talking to myself here! :wacko: Anyway, I ended up going with osPlayer lite and will likely modify the player to automatically play a voiceover.

 

By the way, in the osPlayer lite contrib, the Advanced section of the english instructions has not been updated with the missing </object> tag fix.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...