Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Shop sunndenly stopped working


Guest

Recommended Posts

Greetings all. We have had an OSC shop running quite happily for several months at www.party2go.co.uk.

 

Yesterday the client reported that the shop was behaving erratically. Sometimes items are added to the cart, somtimes not. When you go to the checkout sometimes the shopping basket reverts to being empty and sometimes not. Sometimes you simply can't add anything at all.

 

The maximum number of items we have added has been 3 before the basket has mysteriously emptied itself.

 

None of the above seems to be consistently reprducible so we are at a loss as to where to look for the problem.

 

There has been no change to any of the files and we have tried re-uploading all the files in case there had been any corruption.

 

Totally at a loss.

 

Any suggestions anyone please.

 

Thanks

Link to comment
Share on other sites

Sounds like a sessions problem. Check you have recreate sessions set to true in your Admin/Configuration/Sessions.

 

HTH

 

Julian

A little knowledge is dangerous, I SHOULD KNOW.

If Life Begins At 40, What ends????

Link to comment
Share on other sites

Sounds like a sessions problem. Check you have recreate sessions set to true in your Admin/Configuration/Sessions.

 

HTH

 

Julian

Hi Julian

 

Have changed that setting. It was set to False, but it has had no effect at all. The site was set up in February and not had a problem until now. This is weird.

 

Colin

Link to comment
Share on other sites

I have been having the same problem, seems to work if you login before adding to cart. Happened to 2 of my shops so far.

Link to comment
Share on other sites

I have been having the same problem, seems to work if you login before adding to cart. Happened to 2 of my shops so far.

 

A quick update on our situtaton.

 

Yesterday we took a full backup of the site and database and loaded it up on one of our own domains on a different server.

 

It works perfectly there.

 

For comparison purposes the non working version is at Party2go and the working version is at Creamofcornwall

 

Just to reiterate. Files and databases are identical on both.

 

We will therefore be going back to client and tell her that somthing must have changed on the server she is using and therefor I'm afraid not our problem. We will of course be offering her hosting.

 

Cheers

 

Colin

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...