Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Warning: session_start


mi_jaiten

Recommended Posts

Getting this message across the top of Administration > File Manager

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/siamsave/public_html/admin/includes/configure.php:45) in /home/siamsave/public_html/admin/includes/functions/sessions.php on line 67

 

Also when I try to open a file I get this message:

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/siamsave/public_html/admin/includes/configure.php:45) in /home/siamsave/public_html/admin/includes/functions/sessions.php on line 67

 

Warning: Cannot modify header information - headers already sent by (output started at /home/siamsave/public_html/admin/includes/configure.php:45) in /home/siamsave/public_html/admin/includes/functions/general.php on line 18

 

Anybody know how to clear it, it suddenly happened last night but I dont know what caused it or how to correct it.

 

Kind Regards,

Michelle

Link to comment
Share on other sites

http://www.oscommerce.info/kb/osCommerce/G...mon_Problems/15

 

is a good place to start.

This problem also sometimes happens when a catalog file gets put into the admin area by accident. Usually language files, I think but I could be wrong. Were you adding a contribution or editing something?

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

http://www.oscommerce.info/kb/osCommerce/G...mon_Problems/15

 

is a good place to start.

This problem also sometimes happens when a catalog file gets put into the admin area by accident. Usually language files, I think but I could be wrong. Were you adding a contribution or editing something?

 

Wendy,

 

I read the link you pasted thanks.

 

Done what it said, removed whitespace before <?php and after ?> and hey presto the first message dissapeared then I opened the admin file and got the same two messages, I clicked refresh and they too dissapeared.

 

Thats all is working Ok now many, many thanks.

 

Just one thing maybe you'll know the answer

 

In the Administration Panel > Catalog I get this message:

 

Error: Catalog images directory does not exist: /images/

 

as it doesn't recognise my image folder I have no images showing anywhere in the Administration Panels links

 

Lastly no prices are showing in categories/products and when I press preview also no images or prices but everything shows on my web site.

 

Any ideas?

 

Kind Regards,

Michelle

Link to comment
Share on other sites

a few things, sounds like you need to set permissions on your images to 777.

check for white space at the end of your configure.php file.

set store_sessions in your configure.php files to mysql

Link to comment
Share on other sites

a few things, sounds like you need to set permissions on your images to 777.

check for white space at the end of your configure.php file.

set store_sessions in your configure.php files to mysql

 

1/ Checked permissions already set at 777

2/ No white spaces at beginning or end of configure 2 files

3/ store session already set to mysql

 

Here's my includes/configure.php file can you tell me if it is Ok!

 

Please add any other ideas as to how to cure my problem, thanks.

 

Kind Regards

Michelle

=====================================================

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://siamsavers.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://blue.host-care.com/~siamsave'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'siamsavers.com');

define('HTTPS_COOKIE_DOMAIN', 'https://blue.host-care.com/~siamsave');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/siamsave/public_html/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be NULL for productive servers

define('DB_SERVER_USERNAME', '');

define('DB_SERVER_PASSWORD', '');

define('DB_DATABASE', 'siamsave_osc1');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...