Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Tip: Missing modules in admin pages


Hanzaplast

Recommended Posts

I have been searching this forum for a solution for this problem but didn't find one :'( . Finally I figured it out by myself, and figured other folks might find this info helpful:

 

 

My Administrator -> Modules page was just showing me the path to the modules folder and showing the INSTALL button, but none of the modules would list/show. So no modules for payement, shipping, and Order Total.

 

The problem was this;

 

In both configure.php files (in /includes, and /admin/includes) absolute paths need to be entered for the filesystem. For example:

 

define('DIR_FS_CATALOG', '/home/sitename/public_html/');

 

(FS refers to the filesystem - I guess for PHP includes)

 

The problem I had is that when connecting with FTP to my webserver it only showed these paths:

 

/public_html

 

and

 

/www (linked)

 

refering to the root.

However, in reality the path is a little bit longer than that (specifically with shared or co-located webservers).

 

So in my case the path was not /www/, or /public_html/ but /home/mywebsite/public_html/.

 

Check with the techsupport of your webhost to see what the real absolute path should be.

 

Enjoy :blush:

Link to comment
Share on other sites

  • 2 months later...
  • 3 weeks later...

I had the same problems and solved it in the admin config file by setting the FS lines to the following, edit the WS lines to your file locations:

 

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where the pages are located on the server

define('DIR_WS_ADMIN', '/catalog2/admin/'); // absolute path required

define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN); // absolute pate required

define('DIR_WS_CATALOG', '/catalog2/'); // absolute path required

define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG); // absolute path required

Link to comment
Share on other sites

I had the same problems and solved it in the admin config file by setting the FS lines to the following, edit the WS lines to your file locations:

 

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where the pages are located on the server

define('DIR_WS_ADMIN', '/catalog2/admin/'); // absolute path required

define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN); // absolute pate required

define('DIR_WS_CATALOG', '/catalog2/'); // absolute path required

define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG); // absolute path required

Thanks for the tip, this helped me too!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...