Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

adding pages to the info box


Guest

Recommended Posts

hi ive been trying all day to add a faq page to the info box

www.makeupworld.co.ck

 

i got the link to appear but despite following ALL the tutorials to the letter the link either takes me to a blank page, an error page or a page already there ie about us, conditions etc

the page i created is called support.php which is a clone of the shipping.php

the information.php code is below

i

<?php

/*

$Id: information.php,v 1.6 2003/02/10 22:31:00 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

?>

<!-- information //-->

<tr>

<td>

<?php

$info_box_contents = array();

$info_box_contents[] = array('text' => BOX_HEADING_INFORMATION);

 

new infoBoxHeading($info_box_contents, false, false);

 

$info_box_contents = array();

$info_box_contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_SHIPPING) . '">' . BOX_INFORMATION_SHIPPING . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_PRIVACY) . '">' . BOX_INFORMATION_PRIVACY . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_CONDITIONS) . '">' . BOX_INFORMATION_CONDITIONS . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . BOX_INFORMATION_CONTACT . '</a><br>' .

'<a href="' . tep_href_link(FILENAME_SUPPORT) . '">' . BOX_INFORMATION_SUPPORT . '</a>');

 

new infoBox($info_box_contents);

?>

</td>

</tr>

<!-- information_eof //-->

 

 

ive followed this tutorial to the letter many times

http://www.oscommerce.info/kb/Catalog_Guid...g_Area/Boxes/49

yet the bugger still wont work

at present when i click on faq in the info box it gives the error

The requested URL /FILENAME_SUPPORT was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

but support is there

12 hrs is enough to spend on this after all what i simply want to do is insert a hyperlink!

yet if it takes 12 hrs to put as hyperlink in im ready to quit

any help

thanks in advance

chris

Link to comment
Share on other sites

Sounds like you need to go into your Catalog/includes/filenames.php and define the FILENAME_SUPPORT page. SHould be able to see how to do it by looking at the code on that page.

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

THANKS A LOT i got it to work instantly

what i will say is that ive been in that file many times today and tried all kinds of things

i had already defined the page earlier deleted it and re entered it now it works

many thanks

chris

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...