Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Reviews in the left side


freds

Recommended Posts

Hi guys.

 

I have put reviews in my shop in the column_left.php. I have the same problem as the one in the Live Shops in the osCommerce Site.

The link is http://www.oscommerce.com/shops/goto,12918

See what happens there when you click the review of a product.

 

It shows:

 

BY S

 

S

 

Rating: [s of 5 Stars!]

 

And the photograph is missing.

 

Is it a known bug for osCommerce or is it just my website and the above mentioned?

 

Please have in mind that if I delete the phrase "require(DIR_WS_BOXES . 'reviews.php');" form column_left.php and put it in column_right.php everything seems to work fine.

Link to comment
Share on other sites

Kinda bugged! Check out your language file for product_review_info.php. It's usualy @ catalog/includes/languages/yourlanguage/product_review_info.php.

 

Check if it has any %s...

 

this is the original code from catalog/includes/languages/english/product_review_info.php.

 

define('NAVBAR_TITLE', 'Reviews');
define('HEADING_TITLE', ' %s Reviews');
define('SUB_TITLE_PRODUCT', 'Product:');
define('SUB_TITLE_FROM', 'From:');
define('SUB_TITLE_DATE', 'Date:');
define('SUB_TITLE_REVIEW', 'Review:');
define('SUB_TITLE_RATING', 'Rating:');
define('TEXT_OF_5_STARS', '%s of 5 Stars!');
define('TEXT_CLICK_TO_ENLARGE', 'Click to enlarge');

Link to comment
Share on other sites

Yes there are two %s... It is like the original code, only in the greek language.

I do not think it is a matter of language because the same happens with the example I posted before which is in english. This is not my site, I found it trying to find some sites using oscommerce and have reviews in the left side to see if that works. I did not know if the problem with my site was something I did.

Link to comment
Share on other sites

I have looked more than 60 eshops and there is not a single one site that has reviews at the left and works.

 

Any suggestions? Or is this trully an osCommerce Bug?

 

Could anyone try it with his own eshop (not the live one of course :) ), his developing version and let me and the forum know about the results?

Link to comment
Share on other sites

I have looked more than 60 eshops and there is not a single one site  that has reviews at the left and works.

 

Any suggestions? Or is this trully an osCommerce Bug?

 

Could anyone try it with his own eshop (not the live one of course :) ), his developing version and let me and the forum know about the results?

 

 

Hi yep it's a bug. I have NO CLUE how it happens though.

 

Normally, I have reviews in the right box. It works just fine. I added it to the left box without deleting it from the right box. NEITHER worked in this scenario. Then I deleted it from the right, only had it on the left. Doens't work. It does not show the pic, and both the customer name and the review text only show the first letter.

 

can you say WEIRD!!!

:-)

Monika

 

addicted to writing code ... can't get enough of databases either, LOL!

 

my toolbox: Textpad - Compare and Merge - phpMyAdmin - WS_FTP - Photoshop - How to search the forum

 

Interactive Media Award July 2007 ~ category E-Commerce

my advice on the forum is for free, PMs where you send me work are considered consultation which I charge for ...

Link to comment
Share on other sites

It certainly is a bug (unless one can say that "osC is not designed to show the reviews box on the left" :-" )

 

The solution has been posted many many times, but it is a pain to post the same things again and again :( I really don't understand why osC never releases any bug fix updates, they don't have to do it every day, week or even month. But once in a couple of months would be nice, it would save a lot of people a lot of trouble.

 

Renaming $reviews in the reviews box file should help (maybe it is not exactly right, I don't remember the details).

 

B.t.w. this is one of the bugs that has been fixed in the BTS, so ... ;)

Link to comment
Share on other sites

:-)

Monika

 

addicted to writing code ... can't get enough of databases either, LOL!

 

my toolbox: Textpad - Compare and Merge - phpMyAdmin - WS_FTP - Photoshop - How to search the forum

 

Interactive Media Award July 2007 ~ category E-Commerce

my advice on the forum is for free, PMs where you send me work are considered consultation which I charge for ...

Link to comment
Share on other sites

Yep, that's it.

 

The problem is though that if the bug, and a solution, is found it is "closed". But is is not fixed! The same bug probably won't appear in ms3, but the current version is ms2, so every day/week/month/year a lot of people encounter these same bugs, again and again :(

 

 

ITA ... grrrrrrrrrr!!!

:-)

Monika

 

addicted to writing code ... can't get enough of databases either, LOL!

 

my toolbox: Textpad - Compare and Merge - phpMyAdmin - WS_FTP - Photoshop - How to search the forum

 

Interactive Media Award July 2007 ~ category E-Commerce

my advice on the forum is for free, PMs where you send me work are considered consultation which I charge for ...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...