Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Shopping Cart Tax missing


juggler

Recommended Posts

Hi All

 

I'm sure this is something real dumb but I can't figure it out and after hours of searching the forum I can't find the answer.

 

I have UK VAT setup at 17.5% and it automatically gets added to the product price and it displays fine on the product page. BUT as soon as it hits the shopping cart the prices are then minus VAT and it never gets added back on.

 

I have the UK setup in Countries, Zones, Tax Zones, Tax Classes and tax rate.

 

What am I missing?

 

Cheers

Juggler

Link to comment
Share on other sites

Hi All

 

I'm sure this is something real dumb but I can't figure it out and after hours of searching the forum I can't find the answer.

 

I have UK VAT setup at 17.5% and it automatically gets added to the product price and it displays fine on the product page.  BUT as soon as it hits the shopping cart  the prices are then minus VAT and it never gets added back on.

 

I have the UK setup in Countries, Zones, Tax Zones, Tax Classes and tax rate. 

 

What am I missing?

 

Cheers

Juggler

 

Try this it migh help: http://www.oscommerce.info/kb/5

Link to comment
Share on other sites

Thanks for the quick reply but I've done the setup of tax and it all looks ok.

 

TAX is added to the product when it's diaplayed on the product info screen. It's only when you click "Add to Cart" Once the item is added to the cart it is displayed minus tax and is never added back on even after the checkout has been completed.

 

HELP!

Link to comment
Share on other sites

Actually I've just realised that it's doing something else! Once it returns you back to the home page the prices are all minus VAT!

 

Do you mean returning back to home page after completion of checkout?

Link to comment
Share on other sites

That's what my cart is doing. Any advise on this?

 

Under TAX ZONE I have a setting for Country=United Kingdom, Zone = All UK

 

When your customer enter their county and country eg. West Yorkshire and UK a pull down menu appears which says ALL UK and an error message says sellect one.

 

My problem was that my test user was setup prior to this Tax Zone being setup, once I went into MY ACCOUNT or the CUSTOMERS section of admin and edited the details to include the county it all worked.

 

The fault wasn't with the setup of OS Commerce but the test user!

 

Hope this helps.

Link to comment
Share on other sites

That's what my cart is doing. Any advise on this?

 

Under TAX ZONE I have a setting for Country=United Kingdom, Zone = All UK

 

When your customer enter their county and country eg. West Yorkshire and UK a pull down menu appears which says ALL UK and an error message says sellect one.

 

My problem was that my test user was setup prior to this Tax Zone being setup, so it had no tax zone.... eg.... ZERO! Once I went into MY ACCOUNT or the CUSTOMERS section of admin and edited the details to include the county it all worked.

 

The fault wasn't with the setup of OS Commerce but the test user!

 

Hope this helps.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...