Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Warning: Cannot modify header information


jimtsik

Recommended Posts

when i'm trying to login to my shop , i get this message .

 

Warning: Cannot modify header information - headers already sent by (output started at /home/khposgr/public_html/newshop/login.php:26) in /home/khposgr/public_html/newshop/includes/functions/general.php on line 31

 

and the page crashes

 

when i'm going as a new customer , everything is ok

but as an old it crashes .

 

pls help me , the shop is live and it works ...

Link to comment
Share on other sites

when i'm trying to login to my shop , i get this message .

 

Warning: Cannot modify header information - headers already sent by (output started at /home/khposgr/public_html/newshop/login.php:26) in /home/khposgr/public_html/newshop/includes/functions/general.php on line 31

 

and the page crashes

 

when i'm going as a new customer , everything is ok

but as an old it crashes .

 

pls help me , the shop is live and it works ...

 

Go into the 2 files mentioned.

 

Place your cursor before the very first <?php tag and make sure there is no white space (spaces, carriage returns etc) before it. Do the same with the very last ?> tag, there should be nothing after it.

Link to comment
Share on other sites

Go into the 2 files mentioned.

 

Place your cursor before the very first <?php tag and make sure there is no white space (spaces, carriage returns etc) before it.  Do the same with the very last ?> tag, there should be nothing after it.

 

 

i did it , i know the problem , i also checked the index.php at main catalog and in my language catalog and a lot of other pages to be sure that there is no any character after the ?>

when i go back with my browser and going to the main page , i'm in like a customer !!!

i can't find it !

i haven;t changed anything else .

pls help me

thank you a lot

Link to comment
Share on other sites

i did it , i know the problem , i also checked the index.php at main catalog and in my language catalog and a lot of other pages to be sure that there is no any character after the ?>

when i go back with my browser and going to the main page , i'm in like a customer !!!

i can't  find it !

i haven;t changed anything else .

pls help me

thank you a lot

 

post your login.php page

Link to comment
Share on other sites

Problem is probably in the login.php language file include. Check this, too.

 

 

here is my language file login.php .

i checked also that in another e-shop of a clint of my , this problem also appeared !!!

I can't understand why . I checked all the pages ( general.php , and login.php ) and they seemed to be ok .

 

<?php

/*

$Id: login.php,v 1.14 2003/06/09 22:46:46 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

define('NAvb script:session_win();">[Πληροφορίες]</a>');

define('TEXT_GUEST_CUSTOMER', 'I do not want to create an account.');

define('TEXT_GUEST_CUSTOMER_INTRODUCTION', 'Choose this option if you just want to checkout. You will still need to give us your Billing Address on the following page but we will not create a Password Account for you. <br><br>Please choose <STRONG><font color="#000000">Returning Customer</font></STRONG> if you have already registered your E-Mail address with ' . STORE_NAME . '.');

?>

 

 

it also appears at the english login page the same problem .

so it must not be from these pages ....

Link to comment
Share on other sites

Another solution...

The problem can be solved by walking through the code logic flow in the files involved, which are mentioned in the warning message, to make sure no headers are being set after content has been sent to the client.

 

Meaning make sure the pages do not have double code somewhere. Usually happens when contributions are added, or layouts moved around.

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

Another solution...

The problem can be solved by walking through the code logic flow in the files involved, which are mentioned in the warning message, to make sure no headers are being set after content has been sent to the client.

 

Meaning make sure the pages do not have double code somewhere. Usually happens when contributions are added, or layouts moved around.

 

 

my friend , there is no double code nowhere !!

i 'm sure about this , because i didn't changed anything a long time ago ...

the problem appears when my hosting company , changed his server !!!

but in these days i installed another oscommerce e-shop for a client , and it's working properly ..

any other idea from the configuration files maybe ?

thank you a lot !!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...