Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

INSTALLATION ERROR MESSAGE


jewels

Recommended Posts

I am trying to install OSComm on my Macintosh and when I get to this screen:

http://[mycomputer].local/catalog/

 

I get this message and cant continue installation..

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

Does anyone know how to enable it???

THANKS!

Link to comment
Share on other sites

Open php.ini in a plain text editor and set:

 

register_globals = On

 

Don't forget to re-start your server :D

 

Matti

Link to comment
Share on other sites

Open php.ini in a plain text editor and set:

 

register_globals = On

 

Don't forget to re-start your server  :D

 

Matti

 

Can it resumed after installation/configuration for security risk?

 

Best Regards,

 

Yan.

YaNotCook !!

Link to comment
Share on other sites

Can it resumed after installation/configuration for security risk?

 

Best Regards,

 

Yan.

 

There are not any register_globals security issues with osCommerce. On my own site I enable register_globals using htaccess (my host allows this). There is a setting in the default osCommerce .htacces file for this to be enabled.

 

Matti

Link to comment
Share on other sites

Open php.ini in a plain text editor and set:

 

register_globals = On

 

Don't forget to re-start your server  :D

 

Matti

 

 

Hi again Matti,

I am working on a Mac. I have found the php.ini file but it doesnt automatically open so I open it in text edit but after I change: register_globals = On

What do I do with the file as I cant save it as a .ini from text edit.

 

CHeers, Jewels

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...